Jump to content

USD instancing isn't working as it should

Recommended Posts


I am trying to scatter some USD assets on my scene.

I have a USD file that has different variants and even though I am scatering the collection randomly, it still just scatters
all the objects together everywhere.

What am I doing wrong?

I am also attaching the hip file and some screenshots.

Thank you in advance.






Link to comment
Share on other sites


So, after some trial and error, I bypassed the collection node, added a configurelayer node after the explorevariants and selected Flatten Input Stage (the instancer kept begging me to do that basically). In the instancer, instead of using the collection in the Prototype Primitive section, I added /explorevariants2/ForestDebris/* and it worked.

I can't for the life of me understand why this worked and not the collection as it should have but this is the solution I found and hopefully it will help someone else.

Link to comment
Share on other sites

Update 3

The materials didn't work because... the instancer removes the UVs by default for whatever reason.

So, if you add ^uv or leave all that space blank, the materials are all working fine...


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...