Jump to content
magneto

How to fix help file errors in H13 and H14?

Recommended Posts

Hi,

 

Sometimes when I am browsing the help inside Houdini, I get this text printed to Houdini console:

 

Exception happened during processing of request from ('127.0.0.1', 62960)
Traceback (most recent call last):
  File "C:\PROGRA~1\SIDEEF~1\HOUDIN~1.13\python27\lib\site-packages\paste\httpserver.py", line 1062, in process_request_in_thread
    self.finish_request(request, client_address)
  File "C:\PROGRA~1\SIDEEF~1\HOUDIN~1.13\python27\lib\SocketServer.py", line 334, in finish_request
    self.RequestHandlerClass(request, client_address, self)
  File "C:\PROGRA~1\SIDEEF~1\HOUDIN~1.13\python27\lib\SocketServer.py", line 651, in __init__
    self.finish()
  File "C:\PROGRA~1\SIDEEF~1\HOUDIN~1.13\python27\lib\SocketServer.py", line 710, in finish
    self.wfile.close()
  File "C:\PROGRA~1\SIDEEF~1\HOUDIN~1.13\python27\lib\socket.py", line 279, in close
    self.flush()
  File "C:\PROGRA~1\SIDEEF~1\HOUDIN~1.13\python27\lib\socket.py", line 303, in flush
    self._sock.sendall(view[write_offset:write_offset+buffer_size])
error: [Errno 10053] An established connection was aborted by the software in your host machine

Anyone knows how to fix this because it's so annoying :(

 

 

 

Thanks.

 

Share this post


Link to post
Share on other sites

do you have a firewall that might be preventing it from launching the help server?
how's the pyqt help browser performing?

  • Like 1

Share this post


Link to post
Share on other sites

Thanks I have a firewall but I did allow Houdini when Windows asked for it. I asked support but it didn't help unfortunately.

 

The new browser is the same. I didn't restrict Houdini from the internet or anything.

Share this post


Link to post
Share on other sites

Thanks I have a firewall but I did allow Houdini when Windows asked for it. I asked support but it didn't help unfortunately.

 

The new browser is the same. I didn't restrict Houdini from the internet or anything.

 

Is this intermittent or all the time? Are there any particular help pages that consistently cause it?

 

 

Same problem here in Mac Osx very very very slow ...

 

What is the specific issue? Speed isn't mentioned before

Edited by marty

Share this post


Link to post
Share on other sites

Same problem here in Mac Osx very very very slow ...

I confirm! Loading of pages is very slow and performance while scrolling is far from good.

  • Like 1

Share this post


Link to post
Share on other sites

I hear the scrolling is fixed once the daily builds kick in.

 

You can set the help browser to external with HOUDINI_EXTERNAL_HELP_BROWSER to 1. That should make it full speed.

  • Like 2

Share this post


Link to post
Share on other sites

Is this intermittent or all the time? Are there any particular help pages that consistently cause it?

 

It is intermittent. So not particular pages. It's like you open the help go to a page, it happens and the console opens, you close it, visit a few more pages, it opens up again.

 

I googled the errors before but didn't help. I didn't really change in windows to cause this so I am lost.

Share this post


Link to post
Share on other sites

Okay check to see if that HOUDINI_EXTERNAL_HELP_BROWSER=1 works until we decipher those error messages!

Edited by marty
  • Like 1

Share this post


Link to post
Share on other sites

Those OP errors started happening on OsX too, but since Houdini was launched from the terminal they were written only there.

 

No window popped up to distract - it would be good to try launching Houdini from the command line tools and see if it fixes the popping up window.

  • Like 1

Share this post


Link to post
Share on other sites

So you are getting them too? I always launch from the Start menu. Maybe people are launching from the command line like you said? I don't know why though.

Share this post


Link to post
Share on other sites

The errors only appear rarely - though I'm not using Help much, and they only appear in the Terminal window. No dialogs ever popup on OsX.

Share this post


Link to post
Share on other sites

For me it appears in the console which is a modeless dialog but it's still annoying since it comes back next time it happens after you close it.

Share this post


Link to post
Share on other sites

I confirm! Loading of pages is very slow and performance while scrolling is far from good.

 

I have reported this as a bug, and SideFX confirms other reports, too. Sounds like they are working on ironing it out.

  • Like 2

Share this post


Link to post
Share on other sites

If you minimize rather than close, then you can ignore further messages.

 

Yes but I also use the console to print out debug information sometimes in python and vex.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×