Jump to content
nigelgardiner

Installing hqueue client requires python2.* but ubuntu 16.04.3 server ships with python3?

Recommended Posts

Hi there

I'm trying to install Hqueue client on a dellr710 server which is running ubuntu 16.04.3server which is now shipped with python3 only.

I get python errors when trying to install and I now see on the Hqueue server interface that Hqueue client requires 2.5,6 or 7.

Can I just install 2.7 and all will be well?

Reason I ask is I had a lot of problems with 2.7 and 3 both being installed on another machine recently and I don't really want to revisit that mess.

 

thanks

Nigel.

Share this post


Link to post
Share on other sites

Yes, both Python 2.X and 3.X can be on the machine at the same time. Python 2.X is usually just the command "python" and Python 3.X is usually the command "python3" so once installed it should work fine. You can install Python 2.X on Ubuntu 16.04 with the command below.

sudo apt-get install python

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×