Jump to content

Search the Community

Showing results for tags 'noise displacement'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Lounge/General chat
    • Education
    • Jobs
    • Marketplace
  • Houdini
    • General Houdini Questions
    • Effects
    • Modeling
    • Animation & Rigging
    • Lighting & Rendering
    • Compositing
    • Games
    • Tools (HDA's etc.)
  • Coders Corner
    • HDK : Houdini Development Kit
    • Scripting
    • Shaders
  • Art and Challenges
    • Finished Work
    • Work in Progress
    • VFX Challenge
    • Effects Challenge Archive
  • Systems and Other Applications
    • Other 3d Packages
    • Operating Systems
    • Hardware
    • Pipeline
  • od|force
    • Feedback, Suggestions, Bugs

Found 2 results

  1. Greetings all, I’m a relative noob in Houdini and am having a hard time trying to create a displaced noise on the mesh of a Houdini Labs Tree Trunk object. Though the Tree Trunk node is open for exploration, I don’t know enough to understand why the following is happening: I try to displace points on the trunk’s surface with procedural noise in an Attribute VOP, using a typical setup (Adding the N value to the P value), but the result appears to not push things outward, 1 to 1. (It looks like maybe things are being pushed according to a tiled UV? I can’t quite tell). I also tried using the Displace Along Normal VOP node, but can’t seem to get that working either. On the other hand, when I use an Attribute Noise SOP, I get the effect I am looking for! What is the big difference here? It appears that the noise here is working on the incoming P value, though when I change it to N, I get nothing. There are another 2 components to this I’d like to solve: With the Attribute Noise SOP, the noise displaces the entire mesh off of its center. This appears to be true no matter which range value preset I use, including ‘Zero Centered’. I would attribute this to the notion that only the points’ position values are being displaced according to the noise, and they’re not being added to their normal values for that center-outward displacement. Is there a way to do this using this node? Perhaps with an expression in one of the fields? As mentioned above, I tried to use a VOP for this, but was unable to achieve what I wanted - (I suppose that ideally someone can show me how to achieve what I need using the Attribute VOP in the first place). The other thing I’d like to achieve is some falloff, where parts of the tree mesh are or are not affected by the noise SOP. The only way I vaguely know of to do this is with an Attribute Transfer SOP and a color value run over P value, however, I hit the wall of shame when trying to figure out how to use those color values to drive the noise that drives the point position values. I imagine it can be done in a Wrangle or a VOP. I tried a few things that way, but coming up with zilch. Hoping someone can help a frustrated beginner! File is attached! (WARNING: requires Houdini Labs’ Tree Creator assets to be installed) Preemptive thanks! NpF LabsTrees_Displacement_Test_v001.hiplc
  2. Greetings all! I’d like to know if it’s possible to pipe any one of the Maxon/Redshift noises into a SOP node in order to displace geometry on a mesh (rather than having Redshift handle the displacement at render time). I need to do this for the following reason: Maxon/Redshift has the specific noise I want (don’t want to spend a lot of time trying to replicate or approximate using one of the SOP noises). I will need to generate vine growth along the object I will be displacing with noise, so unless I’m mistaken, using render-time displacement is not an option. If there’s some workaround to this I haven’t considered, please enlighten me!!! Preemptive thanks for any responders! NpF
×