Jump to content

Houdini HDK Library colliding with gcc /clang ? in OSX

Recommended Posts

I don't know if it is something to do with Houdini for Mountain Lion using clang.. (not gcc)

I had gcc 4.2 which was installed from XCode "Command Line Tool" and tried gcc 4.7 or clang but all of them having same error.

I am having a compile error which is weird because it was working by yesterday and it just won't compile with below error now.. (DESPERATELY NEED HELP)

ld: symbol(s) not found for architecture x86_64

collect2: ld returned 1 exit status

and compile command below

gcc -o test test.cpp

This simple code below won't compile.

#include <iostream>

int main(){

std::cout << "SAO" << std::endl;

return 0;


I've tried putting -m32 just in case but still give me error below.

ld: symbol(s) not found for architecture i386

collect2: ld returned 1 exit status

Using Mac OSX Lion, installed Xcode command line to run command on terminal. It used to work and it just won't work anymore for any of my other codes..

I tried to re-install my command line tool but still same errors.

Please Help me.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...