Jump to content

Packed Object, @active variable and given speed


Recommended Posts

Hello everyone,

I'm doing a simulation with debris falling from a wall, spreading out like a little explosion, i.e., they have a starting velocity and they have been packed, nothing fancy.

Everything works fine, but I need to activate single debris at specific frames, information stored in an attribute.

I'm using the method shown in the MasterClass Bullet about having a SOP Solver to activate the debris, but I don't know why, it puts the starting velocity of frame 1 to 0,0,0 on frame 2!!!

The debris fall at specific frame as supposed they have to do, but there is no more the starting velocity giving that little explosion behaviour.

How can I solve this?

Thank you in advance.

Link to comment
Share on other sites

Hey, Michele


I was able to make your scene work by putting the point SOP inside the SOP solver, check the attached file.

I think that that active DOP somehow shifts the initial frame of your dop object on the left, and that's why it is catching the initial velocity of your fragments, while the one on the right doesn't.

Also note that since you set your velocities on in SOP as a variation of position of the parts, and then you set the initial position of the object in DOPs, it turns out a bit different than the SOP solver version cause the object is already translated to the right before setting the initial velocity.




Edited by rafaelfs
Link to comment
Share on other sites

Hi Rafael,

I'm really sorry I uploaded the wrong file, this is one is the right one and similar the case I'm working on.

As you could see, the left piece, activated by Active DOP, acts as expected, while the right one, activated by checking its activation frame parameter and the actual frame, just falls down.

I saw your solution, but I think doesn't fit my actual situation.

Let me know what you think.


Hi Reny,

which build are you using? Can you try with this new file?

Thank you.


Edited by thinkinmonkey
Link to comment
Share on other sites



I can see your sim working fine regardless bypassing the activate node or not.

On frame 12, it start snapping and upper part of the tube fly away.

I'm on build 314.

It definitely doesn't work on mine, build 314 or 315...

I wonder if it's a linux issue? Just tried on my mac and still doesn't work properly. It seems to be a linux issue, at least for CentOS 6.2. Iinstalled build 314 on my mac and it works perfectly now... :(What is your system, Reny?



Edited by rafaelfs
Link to comment
Share on other sites

@Michele, I think bullet solver did that resetting if your object is not active on simulation start, bullet is very efficient at putting things to sleep(otherwise it would have potential movement and energy that effects anything collide onto it), so that's my guess. Only sidefx guys can answer this.


@Rafael, I'm using the evil but working Windows 7. I eat Houdini crash for breakfast. LOL.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...