Jump to content

Smoke sim motion blur - passes? Not lining up with CG

Recommended Posts

Hi guys -

I have an alembic file that I'm generating smoke from. It's a truck flying past - 

When I render the cloud sim, I render it with motion blur, because my understanding is this is the best way to do this ... (as opposed to rendering with a separate velocity pass? Is that even possible with a pyro sim?)

I use the alembic as a matte in Houdini - but when I comp them together, they don't line up perfectly. See attached.


I've checked the obvious... i.e frame number, etc


  • Like 1
Link to comment
Share on other sites

Yack - i need some help here. I am starting to suspect it is because there is motion blur rendering on the alembic node... but it doesn't turn off when I disable "Geometry Velocity Blur" on the geo node for the Alembic!




Link to comment
Share on other sites

I don't see motion blur on your truck. Did truck from picture render by houdini or you rendered only pyro in Houdini with truck matte?

Try to render only alembic (without pyro) and check does motion blur on it works properly. If not, you don't have velocity vectors on alembic, so re-export it with velocity vectors or recreate new one using trail SOP (unpack geometry to polygons first by convert SOP and ensure check box Geometry Velocity Blur is checked on ). Test that on some frame in the middle, and not first frame. When you get proper motion blur on truck gap will probably disappear. 


Link to comment
Share on other sites

Ok thanks - I'll try that.

I now realize that I do want my alembic to render with motion blur, because the matte should have motion blur too - but it should match up exactly with the motion blur from the Maya render (the primary CG pass). Correct? 

Which is a bit difficult, since the motion blur for the CG pass will be done in Nuke, using Motion Vector passes from Maya. 

Link to comment
Share on other sites

It could be tricky especially for fast rotating objects (like wheels ) on translating geometry (truck) + camera moving .

Once you get proper motion blur on your matte (you have velocity on alembic) you can render that velocity in new pass from Houdini and use it in Nuke for motion blur. That way matte motion blur will match with velocity properly.


1. Create blank geometry node, dive inside and delete File node

2.  create ObjectMerge node and pick all your truck parts from alembic. Be sure to chose InsideThisObject for transform option.

3. create Unpack node and connect its input to ObjectMerge output

4. Create Trail node connect its input to Unpack output, and chose ComputeVelocity. Also turn On Compute Angular velocity

Now, you can hide all your alembic nodes and use this geo1 for matte. It will have proper velocities. Don't forget to turn on Geometry Velocity Blur on render->sampling tab of that geo1.

Edited by djiki
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...