Jump to content

Bullet TransformPieces problem

Recommended Posts


So I got some weird thing going on with transform pieces. Everything was working well untill i set the sim for the whole system.

I can see that even bullet sim is ok, transform pieces sop does not transform properly. When I broke the system into smaller pieces I noticed that actually transform pieces does work, but just for some time. Then is starts to match wrong pieces and everything is weird. In my scene it starts to behave this way in frame 222, before that its all ok.

If you have time, please look into the example. I tried to make it as easy as posssible and also to keep it close to my setup.

Any help is welcome, because Im stuck on it since yesterday and Ive run out of ideas whats going on


Edited by JJ FX

Share this post

Link to post
Share on other sites

Many people post this problem, have you searched the forum?..

transformpieces uses the name attribute to match correctly, if it's not matching up your name attribute is wrong..

Make sure you have made a unique prefix for each fracture, there is this option in both voronoi and assemble. If you have not, all pieces will be named piece*, and will overwrite. As why it works for you in smaller cases, but when you add other parts they share name attribute and transformpiece confused

Share this post

Link to post
Share on other sites

Actually I got some help and know the issue now. I was deleting points inside sopsolver. Istead for deleting better to send to sleeping:

if(@P.y < 75){ i@bullet_sleeping = 1; }

Share this post

Link to post
Share on other sites

Yet I still get the issue when I have more than one name attribute. It works well as long I name everything the same. When I have more name attributes it get confused.

Another thing is that the field  Attribute in TransformPieces SOP works for anything that does not match 'name'. And thats really confusing because I want to match by attribute 'name'

But when I use 'name' it does not tranform at all. When I use anything else, anything, even 'blahblahblah' it does work. 

So eg in my example I have two different objects , one with name attrib 'concrete' and other 'pillar'. When I sim only 1 object and use as an attribute for TransformPieces SOP 'blahblahblah_I_Hate_YOU' it works really well! confusing....

And once I sim one more object that has different name attrib, TransformPieces gets completely confused and does stupid things. 

I dunno, a bug?

Share this post

Link to post
Share on other sites

Ehm looks like your a little tangled m8..

Typing a arbitrary attribute and it working makes zero sense..

Simply have a 1:1 ratio of the name attribute in the two inputs.

The only difference that should be made between your LQ and HQ is LQ got a fuse to reduce point count. Your LQ is simulated, goes into transformpieces, HQ into the other. I'm sure you can understand this..maybe go through your setup slowly and see where you broke this condition.. 

I'll look at ur file when I get a chance on 72 week right now tho

Edited by Yon Anadeyo

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now