Jump to content

native Houdini volume union does not work?!

Recommended Posts

Hey catchyID,

It looks like the problem is coming from the volume bounds.

If you override the volume bounds on the iso offset SOP it fixes the clipping problem.

That's a short-term fix for now. I'm trying to figure out a more intuitive and procedural way to resize the bounds to prevent clipping


If you merge the volumes together then feed that into a volume SOP (making sure the name attribute is density) and volume merge that (into the left input) with each of the respective volumes before your final volume merge/mix that will automatically set the bounds of the volumes.

Edited by coltonmil
  • Like 1
Link to comment
Share on other sites

Thanks :) You are correct. I think it's a bug, don't need to worry about a fix. Another thing, have you noticed that that bottom sphere after isooffset seems has some noise? i.e. it's not a clear fog like the top one? Once more thanks for your help :)

Link to comment
Share on other sites

You can adjust the ray intersect settings in the construction tab to get better results. It should be noted that the top piece is actually giving somewhat incorrect results. It should be displaying more as a shell than a solid object, but the error is working in your favor in this case :) 

Using closed geo should give you better results overall.

  • Thanks 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...