Jump to content
Krion

Evenly spaced Z points in position Noise VOP?

Recommended Posts

Posted (edited)

Hi!

I create these mountains on my shape with a noise by getting that noise by affecting the @P.y attribute. Of course the mountains are thinner when my shape goes more steep, because the points distributed through the Z axis are more dense there. 

To resolve this I thought I should use a different Pos for the noise, so I created a grid and put it in the second input. But when I use getattrib(P) on that input and plug it into the noise, I don't get the expected results. (It seems to do nothing much)

5ce8faf83d8ba_Screenshot2019-05-25at10_20_53.thumb.png.5569754ea4ab31674d2caca413ddae5e.png

Is it that you can't use differents Noise pos' like this? Does the topology have to match with the geometry or something? How does this work, exactly? 

How would one go about evenly distributing the noise position along the Z-Axis? So that you have just as thick mountains everywhere, no matter how steep?

 

Hope you can help me. :) Thanks.

 

Edited by OdForest

Share this post


Link to post
Share on other sites

what you could try, is flattening the position (make the z position 0) before feeding it into the aanoise, if you want to make the noise more "2D"

  • Like 1

Share this post


Link to post
Share on other sites

setting one of the components to 0, with a setcomponent vop

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×