Jump to content

Why am I getting white bake textures?


Bill Mill

Recommended Posts

I’m trying to bake texture using both “bake texture” and “games baker” nodes, a simple Geometry as the LOW RES / Uv object and a hairgen node as the HIGH Res Object, but all my results fail to capture any colors from hair (base color) although the normals seem to be right.

How do I properly bake the hair shader to the texture?

PS: I already tried to disable lighting.

normal_bake.jpg

white_bake.jpg

Link to comment
Share on other sites

ok then i think your issue will be either "Disable Lighting and Emission" on bake texture ROP enabled (you want to disable it to bake a Cf channel), or your shader setup is broken. those two are first things i'd check.

Link to comment
Share on other sites

  • 7 months later...

It took me way too long to figure this out, but I found a usable solution, and it's kinda stupidly simple so I'm surprised it hasn't been explicitly mentioned earlier (unless it actually turns out to be a poor solution, or maybe I'm just really bad at Google).

Using the Labs Simple Baker, I turned off base color and added a custom channel, set the attribute name to Cd and suffix to whatever. Then when you bake it, that custom channel will have the colors from the Cd attribute.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...