Jump to content

Python returns 'module has no attribute' when using python path to reference module, works when storing in 'python3.7libs'


Recommended Posts

I started off creating shelf tools, worked fine then I wanted to read modules on disk so i used the PYTHONPATH variable which worked great. However the second I go to run functions from my module I get the error 'module has no attribute' as shown below. 

import mymodule


it returns the error: module 'mymodule 'has no attribute 'myfunction'.

My workaround right now is just symlinking my .py file into the /python3.7libs directory which reads fine for the moment.


Edited by Latimerias
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...