Jump to content
Atom

[SOLVED]Fire Emission Too Noisy

Recommended Posts

Atom    516

Hi All,

I have a character walking by some fire. The fire is a .bgeo.sc sequence of a pyro sim that is shaded with the fire shader. The emission from this shader does light my character but it is too noisy to be of use. I assume I can't actually turn a pyro sim into a geo light so I have no controls for increasing the sample count for the emission. Is there any solution for this kind of scenario?

post-12295-0-57434800-1454944422_thumb.j

Edited by Atom

Share this post


Link to post
Share on other sites
Annon    78

No you CAN use the pyro sim as a geo light.

Just point the light at the sim and the shader, probably best to turn on point clouds. Hey presto!

Share this post


Link to post
Share on other sites
Atom    516

I tried your suggestion and I can make a geo light but it does not really work. It acts as an area light with a single color, not my flame color.

 

When I enable the Point Cloud option for the geo_light Mantra just barfs an error.

"Point cloud handle referenced before it was opened. Was pcopen() called?"

 

I tried turning on and off all the check boxes and changing values along with pointing the file to a valid folder on the disk instead of the temp: memory file but nothing works. The error persists and darkness is rendered...

 

I guess this feature does not really work in H15.368. I have attached a simple example to show the problem.

post-12295-0-56089400-1454948733_thumb.j

geo_light_point_cloud_issue.hipnc

Edited by Atom

Share this post


Link to post
Share on other sites
Atom    516

So does this technique work for you?

 

My experience is still a black render as if the light does not exist. I assumed this was related to the error.

Share this post


Link to post
Share on other sites
Annon    78

I use it all the time, but I'm not in 15 yet.

I'll have a look tomorrow if you're still struggling.

Share this post


Link to post
Share on other sites
Atom    516

Thanks, I have sent my example file to SESI so maybe it is operator error but something might have changed between H14 and H15 as well.

.

.

.

There is also a second problem. I am using the Fire shader, which has emission built into it. When you create a geolight, the shelf tool turns off the source for the geo light. This effectively removes the flames from rendering in my scene. When I turn on the Render Light Geometry checkbox all I get is an area light, not my flames. So I leave this off and turn back on my flames. This, once again, introduces the emission noise into my scene.

 

Is there a way to turn emission off for the flames shader without affecting the look?

Edited by Atom

Share this post


Link to post
Share on other sites
Rio.Dominia    2

u must change the pixel samples value higher. Such as 9 x 9.   and, change the value of the division size in the dop network.

 

It maybe help.  

 

another solution way is to use the isooffset node to change the volume cache to the geometry , after that,use the geometry as a geometry light.

Share this post


Link to post
Share on other sites
genesys    0

Hmmm, this is odd. Atom, your scene works fine for me. Even turning on render light geometry on the geolight works. I'll download and try it from the version you're using in a bit.

Edited by genesys

Share this post


Link to post
Share on other sites
Annon    78

So the trick around emission noise is that it can't light itself. If you have a single geo node that has the pyro sim in it and point the geo light at that, then it's not working, it's just using volume samples and Ce emission. Crank them up and you start to remove your nosie (and your hair cause it's going to take a while).

 

If you create a new geo node, object merge your sim into it and point the geolight at that, then what's it's going to do is generate the point cloud from that object and use it as a direct light on your original pyro sim. Make sure you generate pointclouds and it'll be nice and noise free... Or you could down-res your sim which will also make the light source smoother.

 

It's a stupid little thing, I found it in the docs somewhere daft, but can't find it now.

Share this post


Link to post
Share on other sites
Atom    516

@Lewie: Thanks for the continued development. While the example file you posted does work it also breaks as soon as I replace the cube object with a .bgeo.sc file import.

 

@Christian: I also tried your trick of using an object merge but that fails the same way as well.

 

"Point cloud referenced before it was opened".

 

Works:

post-12295-0-55713800-1456154160_thumb.j

 

Fails:

post-12295-0-65526200-1456154177_thumb.j

 

So is there something else I need to include in my .bgeo.sc sequence that is currently missing? I currently have density, temperature and heat.

I notice fuel and velocity are not present in my .bgeo.sc sequence. Are those requirements that the geo light needs?

 

How would I add them to my export?

I don't recall explicitly removing them from output. I just placed a ROP Output node at the end of a DOP Import pyro sim to generate my .bgeo.sc sequence. It looks like the ROP Ouput throws away whatever is marked invisible.

Edited by Atom

Share this post


Link to post
Share on other sites
Atom    516

Thanks again Lewie for the example file! If I use my .bgeo.sc in your pyro_render geo node it starts working. I see the Generating Point Cloud message and get a fairly noise free render.

Share this post


Link to post
Share on other sites
tinyhawkus    3

Strange though. I don't any PC message at all. You can just save them out by setting up a dummy mantra ROP and running that.

The PC write is strange, you'd think there'd be a PC write inside the shader that the Volume light is looking at, but nope. 

It's doing some sneaky stuff. 

 

You can reduce your noise by simply jacking up pixel samples a bit. The PC quality can be dropped to half of what it's currently set at.

Maybe I'll make a PC write ROP to make life easier. Sometimes the PC temp from the volume light was crashing my renders on the farm.

 

If you need any more help just sing out dude.

 

Lewie

Share this post


Link to post
Share on other sites
ragupasta    1

well this seems like the place to put this as others have had this issue. 

Lately during smoke and fire sims, the volume light works perfectly for me. Never had an issue with the pyro stuff. Well I'm trying something a bit different. I'm having a go an interior rendering which is something I don't really see much of from Houdini users. The model is from Jeremy's site at 3drender. Well I was trying to find a work around from using a lit fog shader with an atmosphere object as it always takes an eon to render even at low settings. So this time I'm going for using geometry converted to volumes as a volume light shaft.

Scene is simple. Lighting standpoint, 1 spotlight from outside simulating sunlight. A second light in exactly the same position to light the volume only. A portal light at the outside of the window as a blue fill light, and an area light inside from the ceiling down to add a bit of internal warm fill.

Ok so, volume is like this: Box geometry converted via isooffset with 50 divs. Name set to density. A billowy smoke shader is driving the shading of it. Volume light added with the isooffset object node as the geometry container that the light needs to point to. Shader the light needs to point to is the billowy smoke shader. Now at the moment the volume light is absorbing all the light within the volume. The PC open issue other have reported is what I'm getting. 

So hitting the render button starts the scattering for the lighting. Does this happen in the density of the geometry or the density attribute inside the shader? Geometry level it is a solid volume with no noise added in any way. In the shader there is also no noise but the density attribute is set quite low, as it is a subtle effect i'm after. Could this be the cause of the issue?

volumeLight.JPG

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×