Jump to content
Sign in to follow this  
tagosaku

apply boolean twice problem

Recommended Posts

hi, when I try to use a boolean node twice, second boolean result is always broken because I guess a connectivity issue. Houdini  cannot understand the connectivity from first boolean result.
 
I know some people says to cut together with many cutters, but I have a certain situation to cut separately. For instance first boolean produces 500 pieces, and keep 300 pieces and use second booleans for other 200 pieces, and so on.
 
Some artist do after-1st-boolean > loop start > delete all pieces(groups) except one favorite piece > do-2nd-boolean > loopEnd > merge together.
Or, I do translate and separate each other of pieces in order to make spaces between each pieces, then apply 2nd boolean, and it works
 
I wonder if anyone knows smarter methods, instead of translating or looping

booleanTwice.hipnc

booleanA.JPG

booleanB.JPG

Share this post


Link to post
Share on other sites

I tested with one Boolean using 2 cutters in one go...it works...but since you said you sometimes have no choice but to do multi Booleans...I guess the problem is everytime you shatter...it creates a lot of coincident faces (where the cuts are)...then in your subsequent Boolean(s)...if you say Resolve Self Intersections...this is where trouble starts because of those coincident faces....untick the Resolve Self Intersections and you won't get those nasty explosions...

Share this post


Link to post
Share on other sites

For multi Booleans route:

OK, so we know the coincident faces cause problems...well....get rid of them...how ? Cheat !!!

So your cutter sheets are infinitely thin...causing problems..my cheat is to extrude it a tiny bit..by 0.001 and make sure to Output Back !!! Then in the Boolean, instead of shatter, use Subtract and also the surfaces are now Solid...so now there is a tiny gap between the cuts....hey hey...no coincident faces !!! So even with Resolve Self Intersection ON...it doesn't 'shat' itself to pieces....

(reminder: if you were doing a single Boolean, then there's no need to extrude the cutter(s)...)

booleanTwice2.hipnc

Edited by Noobini

Share this post


Link to post
Share on other sites

use a clean node in between and possibly a divide node, to get rid of N-gons

Share this post


Link to post
Share on other sites

I think this is a pretty major issue with the node and it would be good to improve upon if it can be done.  You can have perfectly valid geo upstream, but combining booleans gets nasty with high detail cuts.

Side fx support mentioned to me that part of the issues is discussed in the boolean documentation - they discuss how detriangulation affects precision.  The way I read it (correct me if I'm wrong), internally the node can have arbitrary precision to get a near perfect result, but then when detriangulation occurs, you can have an ngon with non planar faces or even becomes non manifold after points get snapped to a lower hardware precision limit.  On the upstream boolean it can help to change the detriangulation options, or disable detriangulation completely.  It can also help to divide and make sure you only have tris going into the downstream boolean.

This is not foolproof though.

I like the idea of just subtracting thin geo Noobini!

Edited by queglay

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×