Welcome to od|forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

art3mis

[redshift] Light mask not working- how to prevent lights from lighting geometry

Hi
My understanding is that any light names you enter into the Light Mask field will influence that geometry.
So a wildcard ‘*’ means ALL lights will influence and by preceding the light name with a ^ symbol, you can subtract that particular light.

But it is not working for me.
Is there some setting in the RedshiftOBJ parameters that I am missing?

light_mask.png

Edited by art3mis

Share this post


Link to post
Share on other sites

It´s the other way round. You can set the parameter on the last tab (objects tab) of the light. But, yes the syntax is ^/obj/obj_name. There you can set light & shadow contribution. * ^/obj/box would light everthing but the box for example.

Share this post


Link to post
Share on other sites

Thanks,so Light Mask on lights. What then is the purpose of Light mask on Geometry?

Share this post


Link to post
Share on other sites

as far as I know it´s a Mantra Parameter only. But correct me if I´m wrong.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now