Jump to content

problem with Motion Blur and Alembic


Recommended Posts

Hello everyone,


I am having a problem with Houdini and Maya. I am meshing a particle sim in houdini and I want to render it out in Maya with mental ray. When I am exporting the the alembic from houdini I am setting up the file with motion blur option enable but when I am importing it in maya it doens't render with motion blur in mental ray. I have also tried to render it out with maya software with no luck. What am I missing?


Update: In maya when I am rendering I get this message // Warning: (Mayatomr.Scene) : convertvdb1: empty or corrupted UV set map1 detected, ignored // 

// Warning: (Mayatomr.Scene) : convertvdb1: shapes are not equivalent, no motion vectors computed // 
shutter time is set to 180 in maya, in houdini motion blur samples when I am exporting is set to 2.


Here the hip file




Edited by Grucho
Link to comment
Share on other sites

What you can try is to force your motion blur geometry samples to have same topology. The idea is to extrapolate movement between frames using velocity attribute (you can use Timeblend qL for this). Unfortunately I didn't manage to check this solution in your scene, because alembic export is not allowed in non-commercial edition, so try yourself! 


  • Like 1
Link to comment
Share on other sites

Hello Igor, 


thanks for the help. I've tried what you suggested with no luck. Is making some strange artifact with the mesh so it is impossible to use it. Maybe I am missing something. 

Link to comment
Share on other sites

Unfortunately, I do not think that the standard alembic workflow works out of the box with motion blur...Imre Tuske has an alternate alembic rop that will get motion blur working in Maya as far as his otl purports. but I have not tested it yet. I believe that it involves baking the motion vector colors onto the geometry. I don't have a link handy but believe that the otl's are hosted on github...

  • Like 1
Link to comment
Share on other sites

  • 4 months later...
  • 3 months later...

I encountered this problem too (on a fracture sequence) and my conclusion is that the alembic ROP in Houdini is not exporting the data correctly, although I do not think it is a bug but more like a "special case" which is not handled.


I have not had the time to report to SESI yet, but inspecting the abc exported as HDF5 from Houdini did prove that the data was not correct.


Edit: actually using the timeblend trick worked and I can force all time samples in the ABC archive. thanks for there tip! I still think the output of the Alembic ROP should be "fixed" in Houdini vanilla though.

Edited by pbd
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...