Jump to content
kvdo

Light attenuation and scene scale

Recommended Posts

Hi guys,

 

I've run into a phenomenon in houdini which I don't know whether to be concerned about, or glad because it makes things more homogeneous.

 

Basically I've been testing light attenuation in mantra as well as sss settings to determine whether they change based on the global scale of the scene. I would have expected that if I scale my scene up by 10, my area light attenuation would fall off a lot quicker, based on quadratic falloff laws. I expected to see some difference in the appearance of sss as well. Strangely though, adjusting scene scale has no effect on either of these things. I've attached 2 images. one is the scene with a scale of 1, and in the other, everything is scaled up to 10. There is zero visual difference in the two images.

 

Am I right in thinking this is physically implausible?

 

 

post-11886-0-89597800-1427275307_thumb.j

post-11886-0-46491000-1427275310_thumb.j

Share this post


Link to post
Share on other sites
Guest tar

the camera is scaled? that will affect the shading

Share this post


Link to post
Share on other sites

Ah! It seems so obvious now.

 

Here is the scene at two different scales, cameras not scaled.

The third image is the 10*scale scene with the light intensity bumped up to 100.

You can see the sss density is affected as expected, but no change to physical light attenuation. Am I still missing something?

 

 

post-11886-0-61932700-1427286865_thumb.j

post-11886-0-54608600-1427286867_thumb.j

post-11886-0-54426900-1427286869_thumb.j

Share this post


Link to post
Share on other sites

Physical attenuation does not just "happen", it is a result of the light source energy being spread on a larger area, or, thought in a different way, the light source occupying a smaller solid angle when seen from the point being shaded.

If you scale everything up, the solid angle of the light source stays the same, and thus the lighting stays the same - provided that the absolute intensity (per unit area) of the light source stays the same.

I bet you have kept "Normalize Light Intensity To Area" enabled on your area light, it scales down the intensity (per unit area) of the light when it's scaled up. If you disable the parameter, the renders should match even without bumping the lighting intensity by hand.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×