Jump to content
Memo

weird artifact with timeblend +timewarp on FLIP

Recommended Posts

I have a flip + whitewater sim which I've cached with all properties, now I'm slowing it down 4x (i.e. timewarp frames 1...6000 stretched to 1...24000) and I'm using timeblend (i.e. cache -> timeblend -> timewarp -> NULL_OUT)

 

Most of it is working, but for some reason there are some artifacts, some (very few) particles are not being interpolated. You can see what I mean in these videos (I'm rendering as seq of tiff with alpha and I've tried 3 diff alpha matting methods -ignore, straight, premult - and it's noticable on all).

 


(especially obvious when watched frame by frame). 

 

in the link above I've also included a tiny segment of my raw data and a minimal hip file which shows how I'm doing the timewarp+timeblend

 

I have no idea what this is, or even how to debug it. Any ideas welcome!

 

Share this post


Link to post
Share on other sites

did you disable "reseeding" at the FLIP solver? Otherwise you have new particles appearing in the middle of the sim, and obviously those cannot be interpolated properly. 

Share this post


Link to post
Share on other sites

Hi Netvudu, thanks for the reply. yes reseeding is disabled. Also the artifact doesn't look like a reseeding issue. It's not that I get 'occasional pops'. Instead, very small clumps of particles are not being interpolated. instead they are moving every 4 frames (you can see this in the videos - or directly in the hip). I can't figure out what it is about those clumps of particles that make them not interpolate. I've had a look at the geometry spreadsheet (or whatever it's called these days), and I can see my particles have a class attribute, and have values of 1 and 2. I've tried isolating class 1 and class 2, and both classes exhibit the same behaviour (i.e. tiny clumps in both classes of particles don't interpolate). I don't know how else to debug the problem. 

Edited by Memo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×