Jump to content

Can't get a proper OBJ export from Houdini.

Recommended Posts

See the screenshots to see what's going on.

In the OS X preview one side of the wheels seems totally screwed up. And the other side of the wheels a little.

In 'Storyboard Pro' it really is a mess..

See the third screenshot to see what i've already tried.


Here is the file if you want to take a look.



Thanks in advance. :)




Link to comment
Share on other sites

Thanks for your reply. :)

That actually helped a bit, but now they are still both a 'little' screwed up.

As you can see in this screenshot: https://www.dropbox.com/s/0mbu8vmw89ntq25/Screen%20Shot%202016-03-29%20at%2016.17.42.png?dl=0


And in Storyboard Pro it is still the same. So something must be wrong, and i can't understand what.

Link to comment
Share on other sites



I know for a fact that I have huge troubles with obj files at home on my mac...but I'm not sure that is the issue here...

I'm inclined to think that Storybook Pro is to blame...

is it able to import other file formats?

are you able to import the obj in another application and see if it's bad there?

Link to comment
Share on other sites

May be a Storyboard Pro bug indeed.

But I downloaded 3D coat, and there it is also like the Finder Preview.

Still something wrong with the wheels


SBP can import *.osb, *.3ds, *.obj and *.fbx.



I think you need the commercial version of Houdini for fbx right? because it was greyed out.


Edited by DévinOdforce
Link to comment
Share on other sites

When i export a part very early in the chain of the wheel i get this


Tried a reverse SOP but didn't work, it made the viewport and the export black.




Seems like backface culling or something is occuring in the OBJ export



Edited by DévinOdforce
Link to comment
Share on other sites

Inverted normals and "black geometry" problem is super trivial and easy to fix. I'll try to explain how to avoid it. Turn on the Display Options window with D key, go to the Optimize tab, on the Culling grouping check Remove Backfaces. Turn off backfaces while modeling. Personally, I would prefer never to see double-sided geometry in the viewport, but disconnected points are not displayed then.
Your geometry is non-manifold. See how tires and rims are inverted and spokes are facing properly. Note opposite situation for wheels on another side. That's why you should consider other ways of mirroring, or even copy and rotate wheels without any mirroring, like for real wheels.
More specifically, spokes was modeled with reversed winding, then fused to the rims. Polygon's "facing" and normals are different things in Houdini. When you reverse geometry with an existing N attribute, the geometry turns black, because you also need to negate/recompute the N. In other apps it can be achieved with a single "flip normals" operation. You generally should correct the winding in-place by using the Reverse SOP or reversed selection order of entities you perform operations on, reversing checkboxes on used tools, etc. There is no general way of fixing it, since there is no "correct side" on models, but plenty of ways suitable for different cases.


So, how to fix. You have bad topology and normals in spokes's connections, so fusing points (changing topology) and recomputing normals (destruction of existing ones) is not considered bad, I guess. So, just fuse all points, reverse/orient polys and compute fresh normals. If topology-changing operations are prohibited, use Reverse SOP and negate normals by selecting geometry manually. For more procedural setups, just inserting reverse nodes in-place is the fastest way.


Storyboard Pro problem is different. It looks like that the program imports objes with reversed vertex order or expects only triangulated geometry. Try triangulate, reverse, triangulate+reverse options, or use FBX. Blender can import and export FBX and OBJ too.


Edited by f1480187
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...