Jump to content
Sign in to follow this  

Can't get HDK to compile

Recommended Posts

Hallo all.

If been trying to get the HDK to work on my pc, but what ever I try it fails to compile.
I tried both visual studio 2012 and 2015, and using the command line hcustom, I have 2 version of Houdini on my PC Houdini 15.0.465,Houdini FX 16.0.504.8 on a windows 10 pc.

Searching for possible solutions didn't yield any results either, so I was  hoping someone here could help me out.


Thanks in advance


Included are the error logs for both VS.





Share this post

Link to post
Share on other sites

cl : Command line warning D9025: overriding '/TC' with '/TP'

cl : Command line warning D9025: overriding '/MDd' with '/MD'

These warnings say to me your environment variables must be severely messed up. First of all SAVE a copy of all your environment variable values before doing anything else. Now, offhand:

- Remove anything Visual Studio related from your PATH environment. This was only necessary on 32-bit Windows. You *must* be running 64-bit Windows.

- Remove anything that looks compiler related before running hcustom other than MSVCDir. Make sure MSVCDir is pointing to VS 2015's VC directory. Remove these if you see them: LIB, INCLUDE, CFLAGS, CXXFLAGS, or anything else similar.

Now try again using the Houdini Command Line Tools from the Start Menu and hcustom.

Share this post

Link to post
Share on other sites

I Got hcutom to compile a sample node, and it works in 16 event though hcustom crashes afterwards, but that could be the same as another post about it crashing on windows 10.
Unfortunately Visual studio still fails to compile for me at this time. At least i can start with experimenting and learning to make node's / vex functions
Unfortanite i't did not help

I tried 2015 with the latest stable build of Houdini 16 but still it failed.


Share this post

Link to post
Share on other sites

Not sure, I did what you advised and removed or changed some of the environment variables.But I got something to work with

Getting VS to work is just a luxury for me now.
Thanks for the help!

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this