Jump to content

Recommended Posts

Posted (edited)

Greetings!

To anyone using Deadline for rendering Mantra, could you advise what your successfull workflow is, please?

I have a couple of questions about the HoudiniSubmitToDeadline parameters that I can't find definitions for in any docs. This url is the most useful: https://docs.thinkboxsoftware.com/products/deadline/10.0/1_User Manual/manual/app-houdini.html

Q1 - machine limit & Mantra Threads defaults are 0. Do I need to change this value, or is zero ok?
Q2 - "Submit Houdini Scene" is OFF by default. Is this correct?
Q3 - "Ignore Inputs" is ON by default. Which inputs is it referring to??

It's currently only rendering successfully if I DONT generate .ifds first, which is obviously not correct. 
I am ticking on "DiskFile" in the Driver tab of /out/mantra1
Disk file = $JOB/ifds/$HIPNAME/mantra_$F4.ifd
Shared Temp storage = $HIP/ifds/storage
Local Temp storage =  $HOUDINI_TEMP_DIR/ifds/storage

I launch Render->SubmitHoudiniToDeadline
Pool = 3d group = None
ROP to Render = Choose = /out/mantra1
Under MantraExport 
Submit DependentMantraStandalone Job is checked ON
Pool = 3d group = None

2 tasks are submitted, which is normal.  
First task generates .ifds again (I think this can be avoided by select SkipFilesThatExist in /out/mantra1 IMAGES tab
Second task is supposed to write .exrs but fails.  Yes, the folder is writeable.
Pipeline are looking into the error: 
INFO: Process exit code: 1
2018-01-05 17:14:03:  0: An exception occurred: Error: Renderer returned non-zero error code, 1. Check the log for more.
2018-01-05 17:14:03:    at Deadline.Plugins.PluginWrapper.RenderTasks 

Any pointers gratefully received.

Many thanks,
 Olly : )

Edited by ollynash

Share this post


Link to post
Share on other sites

If you don't change the values it will grab all machines or cores available. If you need to change that depends on your needs.

Submit Houdini Scene will make a copy of the hip file in the slave. That means all your paths will have to be properly directed with a variable. Usually $JOB. The default, $HIP, won't work unless you copy all your assets to the slave too. This depends on your workflow, but be aware that if you don't use this option and you change your .hip while rendering, it will change the render.

I *think* ignore inputs refers to rendering multiple nodes in the chain, but don't quote me on that. This would be useful if you want to, for example, cache some geometry first and only when it finishes you want to start rendering.

 

 

Share this post


Link to post
Share on other sites

Hey Vitor,

Thanks so much for your reply, very useful thank-you, most appreciated.

So, zero in limits is good. Ignore imputs makes sense to have ON, unless the cache writing is organised carefully. Ah yes, it comes down to workflow preference as to whether a render node should copy scene locally or not (I remember from old Softimage days there are pro and cons to this).  I use $JOB instead of $HIP everywhere, so I guess that would be ok.   

Olly : )

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×