Jump to content

Strange Icon/geometry Missing(not Rendering?)

Recommended Posts

It's very annoy especially about the geometry part.

After I do something like change modes(OBJ->ROP->OBJ),

or do somthing like preview render, maximize help window, etc.

The icons of both tool bar and network pane are missing, also geometry OGL render disappear after I move camera.

System spec below:

HP xw9300 with Quardo FX1400

Dual Opteron 252, 2G RAM

nVidia driver version 1.0.7676

OS: Ubuntu 5.10

Gcc: 3.4.5(with 3.3.6/4.0.x installed also)

glibc: 2.3.5

Houdini: houdini-8.0.383-linux_rhEL4

See screenshot taken below.

I've already tried with HOUDINI_OGL_DBL_BUFFER_FIX.

And I have nvidia CIOverlay option on in xorg.conf.


icons all missing, along with a sphere newly created.


icon missing with model OGL render still there.


Arr....After moving camera, the OGL render is gone too.


Link to comment
Share on other sites

This is most likely a problem caused by the videocard driver, but I'm not sure (it's hard to tell from here). It sounds - and looks - very annoying, so I'm sorry to hear about your problem(s)...

Try addressing this in the SESI mailinglist and/or at the (SESI) forum.

Link to comment
Share on other sites

You can try turning the CIOverlay option off and see if that helps. I've used up to NV driver version 7174, and that one seems to be very stable. 7676 I've never tried because of its dependency on a newer version of libc which my Debian dist doesn't care for, so I'm unsure of whether that would be the issue (though I have heard rumors of strange problems with that driver version, but never seen them).

Link to comment
Share on other sites

Since the problem looks to be that every icon is missing, and it looks like everything else is fine, I would wonder if there is a problem with the file that contains the icons. In $HH/config/Icons there should be a file called Icons.index which is about 1.3MB. If you run "hidx Icons.index" from the command line, it should spit out a huge list of .bicon file names, file sizes, and dates. If not (or if the file is missing), there may have been a problem with your installation or that file got corrupted or lost some other way. Your best bet is to just reinstall Houdini if there is a problem with that file.

If that file looks fine, you should also make sure that there is no Icons.index file located anywhere else in your Houdini path, or Houdini may be trying to use that file instead of the real one.


Link to comment
Share on other sites

Thanks to everyone who reply my post first, although your solution didnt correct my problem, but narrows down the possible of what cause this all.

It's my custom compiled kernel 2.6.13-4, when I change back to stock kernel of Ubuntu 5.10, everything runs so smooth, that I even tried it 3~4 times with rebooting and switch kernels.(and smesh Fn keys like hell XD)

Finally I would like to try 2.6.14, the newest one but failed to boot, so I just use the last linux-tree provide by Ubuntu archives(which is 2.6.12-xx).

Things turns out quite smoothly using 2.6.12 version of kernel, maybe nVidia should try to keep up with new kernels?(I pull out useless modules which enabled with default settings,turn on SMP, change arch,etc..etc..).

Anyway, a big THANK to you guys!!!

I can finally start playing with new houdini 8~~~YEAH~~~


Ren-Wei Yang

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...