Jump to content
Sign in to follow this  
smbell

Viewport openGL specular wierdnes

Recommended Posts

Posted (edited)

I'm trying to get a very basic viewport shader representation going for my redshift shaders, although this issue doesn't really have anything to do with redshift... I've added the Diffuse Texture Layers from the parameter interface and my diffuse texture loads fine, but the material is super shiny. I have added all the specular and various other related parameters, but it seems like the specular value doesn't work at all to lower the specular. I can increase the roughness to 1 and that works, but it's still showing specular, just very rough.  The Enable Specular checkbox also doesn't work, nor does the specular intensity slider. Turning off the specular component in the High Quality Lighting viewport options doesn't work either.

I started from this thread on the RS forums where someone made a nice HDA for the redshift shader to show in the viewport and I was trying to make my own basic version to learn about the openGL viewport stuff.

https://www.redshift3d.com/forums/viewthread/24071/P45/#151805

Edited by smbell

Share this post


Link to post
Share on other sites

Can't view the forum post if I don't have an account. Could you post the relevant details here?

Share this post


Link to post
Share on other sites
23 hours ago, malexander said:

Can't view the forum post if I don't have an account. Could you post the relevant details here?

oh sorry, I didn't realize I was in the customer only section when I pasted that.

This is what the guy said, which seems to be the same issue I'm having, except the issue seems to affect more than just the specular map from my experience.

Quote

Hey all, if anyone is interested in a rs shader with opengl tags (plus texture access from the top level) I’ve attempted a HDA here. As mentioned before, I think I’ve found a bug with the OpenGL implementation within Houdini as the spectral map doesnt get multiplied by the spectral colour. Further, coating tags dont seem to work either. 

 

I can whip up a sample scene and attach the hda when I get home tonight, but it is pretty simple to recreate, essentially none of the openGL specular controls work when added to any shader.

Share this post


Link to post
Share on other sites
Posted (edited)

I think I may have figured out what is causing it.

It looks like the RS light dome is causing there to always be reflections/specular and doesn't seem to respect the openGL settings...

Edited by smbell

Share this post


Link to post
Share on other sites

The ogl_reflect property wasn't properly being sent though to the environment light shader. This has been corrected in 17.5.285. If you want to use specular color to affect the reflection, you'll need the ogl_spectint property set to 1. Generally speaking the ogl_reflect parameter (float, 0...1) is better though.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×