Jump to content

Trouble Setting Up The Hdk

Recommended Posts


I'm having trouble to get the HDK to work (to compile a DSO). I set up all the erv variables and installed the HDK as described in the odwiki article (the windows part) but when I try to compile one of the sample DSOs (for example - I just type "hcustom SOP_Star.c" in the command prompt) I get that message :

F:\Program Files\Side Effects Software\Houdini 8.0.474\toolkit\samples\SOP>hcustom SOP_Star.c Making 'SOP_Star.o' and 'C:/DOCUME~1/sam/MYDOCU~1/houdini8.0/dso\SOP_Star.dll' from 'SOP_Star.c'

Error running cl

Argument list:

0: cl

1: -TP

2: SOP_Star.c

3: -DUT_DSO_TAGINFO="3262197cbf01481903a01f89403d94ee6b108baea501d6a923ff915d530aee8261de65b4ca77695e160aadba72da200a51fbec0affd3f95643062bd277ea81ac5bbe45a0ffd0108ea326de490a90"

4: -TP

5: -DVERSION=8.0.474


7: -DI386

8: -DWIN32


10: -DDLLEXPORT=__declspec(dllexport)

11: -I

12: .

13: -I

14: F:/Program Files/Microsoft Visual Studio .NET 2003/Vc7/include

15: -I

16: F:/Program Files/Microsoft Visual Studio .NET 2003/Vc7/PlatformSDK/include 17: -I

18: F:/PROGRA~1/SIDEEF~1/HOUDIN~1.474/custom/include

19: -I

20: F:/PROGRA~1/SIDEEF~1/HOUDIN~1.474/toolkit/include

21: -Ox

22: -MD

23: -GX

24: -GR



27: -FoSOP_Star.o

28: -LD

9: -link

30: /libpath:F:/Program Files/Microsoft Visual Studio .NET 2003/Vc7/lib

31: /libpath:F:/Program Files/Microsoft Visual Studio .NET 2003/Vc7/PlatformSDK/lib 32:

33: F:/PROGRA~1/SIDEEF~1/HOUDIN~1.474/custom/houdini/dsolib/*.a

34: -out:C:/DOCUME~1/sam/MYDOCU~1/houdini8.0/dso/SOP_Star.dll F:\Program Files\Side Effects Software\Houdini 8.0.474\toolkit\samples\SOP>

error running cl..what is cl?

it creates the output folder but it is empty..

I really don't know whats wrong.. I followed all the instructions

PS: I'm running win XP, Houdini 8.1.655 and VStudio 2003 .NET

any suggestions what the problem could be?

Link to comment
Share on other sites

cl is the C++ compiler of Visual Studio. Make sure, that you have the build environment sourced. I'm in front of a Linux-Box now, so I'm not 100% sure, but if I recall it correctly the command to do this is called vcvars32.bat. It's located somewhere in the Vc7/bin directory of your Visual Studio installation.

Link to comment
Share on other sites

I think the revealing line here is "14: F:/Program Files/Microsoft Visual Studio .NET 2003/Vc7/include". You presumably have se the MSVCDir environtment variable (of hcustom wouldn't run). But you need to set it to a valu with no spaces in it. Instead of "c:/program files/...", use the 8.3 format of the name, so it will be something like "c:/progra~1/micros~1/vc7". Use "dir /x" at an MS command prompt to see the 8.3 format of each directory.


Link to comment
Share on other sites


thanks for your replys :)

unfortunately I could not fix it. I ran the vcvars32.bat and changed the path to:

F:/PROGRA~1/MICROS~1.NET/Vc7 , but there are no changes on the output...

hmm I'm re installing Visual Studio now, maybe there are some problems since I had the 2005 version installed before...

Damn still the same..this is getting realy annoying :( , i'v got no idea whats wrong..

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...