Jump to content
Sign in to follow this  
Noobini

pyro Sparse + openCL

Recommended Posts

01) simple FX

02) simple fireball

03) works a treat...

04) Solving>Advance> Use OpenCL....won't work because in Sparsity, Sparse is enabled as per Help: Sparse does not work with OpenCL

Quote

OpenCL acceleration is currently only supported in dense mode (when Enable Sparse Solving is disabled).

ok.....

05) enable editing of pyrosolver, dive into dopnet1, in Advanced, Sparsity, note the pyrosolver still have both openCL and Sparse enabled AND a nice big red error sign

06) hit play, it works !?!?!?!?! so what is really happening ? is it kosher ? is it flatly ignoring user's request of Sparse and running in dense mode under the hood ?

Share this post


Link to post
Share on other sites

addendum: there are 2 places where Sparse is enabled, the solver and the object. so when they say OpenCL and Sparse combo won't work, I guess they mean OpenCL + solver Sparse + object Sparse

disable either solver Sparse or object Sparse = NO Sparse

conversely, Sparse = both object + solver sparse must be on.

(could be wrong, just starting with pyro here)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×