Jump to content
art3mis

Increasing radius of effect for bullet solver

Recommended Posts

Hi

I have a problem with a bullet solver in a DOP net where it has no effect on the geometry scattered to points because of the scale of the sphere with scattered points.

In the attached you can see a sphere with scattered geos. At a default scale of 1 the bullet solver works. But if I increase the size of the sphere to 3 or more, the bullet solver stops working.

I dived inside the dop network, checked the various rbd nodes but can see nothing indicating radius.

Can anyone help?

bullet_solver_scale.png

copy_to_point_without_intersection_MASTER_3_increase_radius.hiplc

Share this post


Link to post
Share on other sites

Try increasing the sphere radius instead of scaling it up?

Share this post


Link to post
Share on other sites

Can you elaborate a bit more what you mean by "not working" and maybe what you are trying to achieve? Since for me, everything is fine. The only difference is that you get an "explosion" due to touching polys and as soon as you scale the scatter-sphere they no longer touch and don't explode. The reason why they still move once visibly separated is due to the collision padding. Check the Bullet Data tab on the rbdpackedobject to visualize the guide geo as well as the padding.

copy_to_point_radius.gif

Share this post


Link to post
Share on other sites

Hi Dennis

Thanks for the reply. Yes, it is the 'exploding' effect I am after. But I am not animating the explosion.

I am using this effect to prevent intersection of scattered geos when you have a high enough number to that they start overlapping. The attached show what I mean.

At exactly frame 3 in the sim this effect should begin to take place.(begin of explosion)

With the sphere scaled up there is no explosion effect.

There must be some setting on the RBD or bullet solver that compensates for this but I haven't found it

 

intersection.png

no_intersection.png

Edited by art3mis

Share this post


Link to post
Share on other sites
2 hours ago, Atom said:

Try increasing the sphere radius instead of scaling it up?

Atom, nope doesn't seem to work. Also I need this to be more universally applicable to other geometry than just spheres.

Played a bit more. Realize I was focusing on the wrong sub node. Instead of the Bullet Solver I should have focused on the RBD packed Object node. There is a parameter for Collision padding. Voila!

Edited by art3mis
  • Like 1

Share this post


Link to post
Share on other sites

Ah, I get it so it was the padding as mentioned in my previous post(there is also an option to visualize it which makes it easier to adjust). And what exactly did you do? Did you increase it to something higher than 0.02? I am wondering why you would want such a high value since it's not representing the geo and when the scatter sphere is scaled the boxes are not touching and wouldn't need to explode unless you add more of them. Sounds interesting what you are doing though, just curious : )

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×