Jump to content

Geometry saving error

Recommended Posts



I started learning Houdini not too long ago. Watched a lot of tutorials, but newer tried the rendering. 

So i watched the basic lightning and rendering tutorial from the learning section.


My problem is that MPlayer not popping up if i hit render.

My scene is just a simple grid with a sphere with basic lights (point & env), basic material clay.

I tryed the mantra and mantra - PBR nodes, but nothing happens. MPlayer is not popping up automaticaly, after manual launch and forcing it to listen the renderer, i cant get a render.

Flipbook is working fine. So i checked every options in the mantra node , every tooltips and i readed the mantra online help. Still cant get a simple render.

 Ok. I watched a few video tutorials from youtube and vimeo.


If i try to render my camera gives back an error:


Error saving geometry for : \obj\grid_object1\grid1


and after trying to render the camera always jumps back to 0,0,0 and clears rotation.


I tried to render out  other scenes from the net, but no render :S


Tried the render view, only black vew. cant see anything.



Reinstalled houdini and the whole OS.  Still no render.


houdini version : houdini-12.5.615-win64-vc9

VGA driver: NVidia 331.82


I hope someone can halp me to solve this irritating problem.



Link to comment
Share on other sites

  • 2 weeks later...

This is a long shot, but:
I think the problem is in the specified geometry sop: \obj\grid_object1\grid1
Did you read the object from a file? If so then in the file sop there is a parameter that says "Missing Frame" - "Report Error" ; change that to "no geometry". Also it might be the case that  you read the file as a file sequence, then you need to reassign the filepath as a single frame.

Link to comment
Share on other sites

  • 1 year later...

Sorry for the late reply but for the record, I got the same error. My problem was that even though I wasn't missing geometry on the current frame I was rendering, I had a Trail Sop somewhere that referred to one frame before where my file sequence started in order to calculate the velocity. I put a Timeshift Sop to clamp the file to fix it, putting "Missing Frame" to "No Geometry" didn't help probably because the Trail Sop tried to calculate the velocity between a bunch of points and no points at all.


You were right Carlos about issues reading a file though. Good call :)



Link to comment
Share on other sites

  • 1 year later...

And a year or so later I would like to add that this happened to me just a few moments ago.

Here is the scenario...

I open up Houdini and create a new geo object and browse to a mesh sequence.

The playback scrubs fine.

I continue to refine the scene and save it.


When you save your scene, the internal value for $HIP is changed to the new location where the new .hip file resides.

This makes my File node break because the original browse operation generated a path using $HIP.


I think the solution is to try to remember to save your Untitled.hip to the disk as soon as possible. Or at least before you start populating nodes with external file paths.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...