Jump to content
grendizer

Hotkeys not working

Recommended Posts

Hello everybody,
 
I'm still new to Houdini and I'm tring to speed up my modelling workflow by setting hotkeys. The problem is, they don't work.
The 2 first ops I tried to assign keys to are: "Polysplit" and "Edge subdivide".
 
First weird thing, When I search the Hotkey Manager, I can't find these 2 ops. In the Houdini forum, someone told me to ​hold down Ctrl + Alt + Shift while clicking on a shelf tool to open Hotkey manager for that tool. So that's what I did.
Then I set up "edge divide" to ALT+D. If I hover the mouse on the edge divide shelf tool, I can see my shorctut alt+D.
 
So then, I create a new cube, select 4 of its edges, then hit ALT+D... nothing happens.
 
I'm using an azerty keyboard, is this my problem?
 
I set polysplit on ALT+* and I just got it working on the cube. But in other scenes it wasn't working neither...
 
Thanks and see you soon,
G

Share this post


Link to post
Share on other sites
Guest tar

Just try setting to a simpler shortcut; try 'd' - works on OsX. qwerty keyboard.

Edited by tar

Share this post


Link to post
Share on other sites
Thanks but "D" is already assigned to other important Houdini functions, that's why I prefer to set tools on combinations.
 
Today, neither ALT+D nor ALT+* worked. :wacko:

Share this post


Link to post
Share on other sites
Guest tar

'Alt-D' works here. The reason test 'D' only is to identify whether you can successfully assign keyboard shortcuts on a azerty keyboard. You can always reset these keys. The preferences are also held on disk so you can always backup before testing.  Make sure to check the help file, the '?' from the HotKey Manager.

 

Edge Divide is in the Hotkey Manager - see attached.

 

 

post-8321-0-14818400-1441566071_thumb.pn

Share this post


Link to post
Share on other sites
I think I'm narrowing down the problem. So for now my conclusions are:
 

1) On an azerty keyboard, combinations don't work on non-alphabetical keys : $,*,!, etc. But combinations like ALT+D or CTRL+ALT+P work well.
 

2) The speed at which one has to press the keys combination is important. If one press both keys too long, the tool is not activated! :huh:
 
Thanks Marty for your useful help!

Edited by grendizer

Share this post


Link to post
Share on other sites
Guest tar

Seems like a bug with azerty keyboards. That is all working fine with qwerty. It's probably worth submitting a bug to SideFx to ensure this gets fixed.

 

On the SIdeFx.com site, support menu - submit bugs.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×