Jump to content
Sign in to follow this  
noc2

Subdivision Sop Producing bad results

Recommended Posts

Hi;

This has been really bugging me for a while. I have a simple low poly object with beveled edges, with a round bevel and with no vertex splits so as to have the bevel yield quads. Now, when I subdivide this using the subdivide sop, I get terrible artifacts on the inner corners as opposed to the other corners. This, I'm never used to seeing in any other platform that supports subdivision surfaces. I know that the subdivide sop only subdivides and that Houdini does not have a "True" subdivision surfaces support, But I at least shouldn't be getting this :angry: I've literally tried every subdivision algorithm and nothing helped. This is the default the sop gives when laid down, which is Open-Subdiv Catmull Clark.

Is there a workround to remedy this result (pls. see the attached images below)

Cheers;

AJ

image.png.aaa0e4ddb6cdbd2ab890565776d7f275.pngimage.png.b2e8832389f0378f922e88fc0486aa1b.png

Edited by noc2

Share this post


Link to post
Share on other sites

I'm gonna take a stab in the dark, you have a polybevel somewhere in there ? In the poly bevel, untick Allow Vertex Splits...

ahh sorry, you've already mentioned about the bevel...ignore me.

Edited by Noobini

Share this post


Link to post
Share on other sites

Ok, from what I found just now, I can remedy the problem (if one can call it that) by creasing the end edge loops of two adjacent bevel strips and their binding edge rings. But this needs to be done manually and is no where near the procedural nature of Houdini :(

Share this post


Link to post
Share on other sites

Hi Noobini;

Yup, I tried that as well to see what it would do, to no avail I'm afraid. The result is no where near what should be. This is really quite a shame for Sidefx who really get everything else quite right in Houdini.

Share this post


Link to post
Share on other sites

in your bevel, if you disable Ignore Flat Edges...could be your last get out of jail card...run for it !!!

subdiv.jpg

Share this post


Link to post
Share on other sites

Thanx Noobini, but the model really calls for all corners to be beveled :( But thanx all the same...

Share this post


Link to post
Share on other sites

Seems like the subdivide sop is doing the subdivide correct according to your pictures, is it the bevel sop that is the problem? (since the topic is that the subdivide is doing something wrong)

Share this post


Link to post
Share on other sites

Ah, woe is me! So sorry to have causes a ruckus out of nothing guys. A modeler colleague of mine just reminded me today, that when it comes to inner corners on a geometry that has such a 90 degree angled stepping form, the bridging corner edges between adjacent loops need to be beveled as well and showed me that this is universal. Was so tired yesterday and couldn't see straight, hence why I couldn't see it I guess.

Again thanx for all the replies and my apologies :(

AJ

image.thumb.png.3c8e5b034958a50a3039b4707fe2229c.pngimage.thumb.png.331fc69f46868d7857d592dc83199396.png

Share this post


Link to post
Share on other sites
5 hours ago, noc2 said:

Ah, woe is me! So sorry to have causes a ruckus out of nothing guys. A modeler colleague of mine just reminded me today, that when it comes to inner corners on a geometry that has such a 90 degree angled stepping form, the bridging corner edges between adjacent loops need to be beveled as well and showed me that this is universal. Was so tired yesterday and couldn't see straight, hence why I couldn't see it I guess.

Again thanx for all the replies and my apologies :(

AJ

image.thumb.png.3c8e5b034958a50a3039b4707fe2229c.pngimage.thumb.png.331fc69f46868d7857d592dc83199396.png

this is exactly what I said as your last get out of jail card....because you have Ignore Flat Edges on...so your first pic shows a SINGLE 'bridging' line...once that's disabled, it works.

Edited by Noobini

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×