Jump to content
shinsso

when use houdini engine, alpha attribute problem

Recommended Posts

Posted (edited)

hi guys

I did some render test with houdini and maya redshift renderer.

I made particle in houdini then rendered it in maya using houdini engine and redshift proxy file.

 

render_test.thumb.jpg.ad9a6f6b5fdde8fed6dd8886b8eb7d98.jpg

This image is that I tested to compare houdini redshift render and maya redshift render.

A is houdini redshift

B is maya redshift with importing particle by houdini Engine

C is also maya redshift with importing particle by redshift proxy

 

When I use B, alpha attribute for per particle is different from A and C.

Is there any way to correct the alpha attribute?

 

Thanks.

Edited by shinsso

Share this post


Link to post
Share on other sites

Hi I'm not 100% sure with redshift I use vray in Maya as my char anim stuff is rendered there too.

I export out my particles as alembic (promote to vertex before rop alembic export).  In that export is my Cd and Alpha

I bring in my particle sim from hou using the import proxy tool.

I usually need to use a node to connect the Cd attribute to colour on my vray shader.  I use a userdata node and enter Cd into that and then plug that into my shaders colour value. It's picked up.

The same thing happens for my Alpha plugging a userdata node in and setting that to "Alpha" (capital A)

Those are my main ones for my particles. I can also poop out pscale to control particle radius too

 

There may be a similar option in redshift I heard it's very similar to vray.. Worth a bit of a twiddle to see what nodes are in there to do the job?

Share this post


Link to post
Share on other sites

Thank you for your reply.

There were two options I could use to deliver houdini particle to maya as a redshift user.

One was houdini engine, this is very easy to auto match per-particle attribute and value. So, some attributes like pscale, Cd or ID were well matched except Alpha.

I didn't use any redshift userdata node then, I'll try that node, thanks.

And the other was using redshift proxy. I had to use redshift proxy format not an alembic. and there were no options to control per particle attribute in maya.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×