Jump to content
fictionfxartist

Some of the pyro clusters aren't even visible

Recommended Posts

Hi all,
I was working on a project and i had to show a animated object as meteor so i added some sop's and made it pyro cluster, now the problem is when i play it in dop network some of the pyro cluster forcefully stops the object/fire from moving along.
I tried solving it but there was nothing i was able to do.
I will be attaching a screenshot of the how problem looks, if you see the image there are two bounding boxes at distance which was supposed to be side by side and show the swift movement
Also i will be attaching my .hip file and the stone's .fbx file.
Thank you. 9fac3bb2b516c54af0808d889565ba4036eafc6d

Rock1.obj

comet_collision_v06_5.hipnc

Share this post


Link to post
Share on other sites

There are a few problems. One is that you need to Object Merge Into This Object or your fuel supply may be generated outside of a cluster bounds. You are currently basing your fuel supply on the cluster points. You should be basing your fuel supply on a single point that is moving along the cluster line. Consider using a carve followed by a delete all but point zero to achieve this or extract the centroid from the moving geometry to generate the fuel.

Drop down a bounds node around all the cluster points and expand it on the Z axis in both directions. Supply this bounding geometry to the fluid resize node. This will make sure the master domain that the cluster's reside within, are indeed inside the possible simulation box. Make sure your (10,10,10) cluster scale value is actually big enough to contain your initial fuel supply.

Edited by Atom

Share this post


Link to post
Share on other sites

I instead deleted the scale using attribute delete and manually increased the size of bounding box in smokeobject(dop), but yet i am facing the same problem.

I didn't properly get the fuel thing you asked me to do, can you explain it to me again?

Thank you for the reply tho!

Share this post


Link to post
Share on other sites

I already had the video but that didn't pop into my mind until you told me, Thanks for that.

I followed the video everything went well until i started adding fuel, i know there is something wrong with adding fuel but i don't know exactly what.

Probably something wrong with scatter(sop) inside the Make_Cluster_Points(geo).

I am attaching my file over here, i hope you could help and i will also start trying with your file now, lets what that will get me.

Thanks a lot for everything and so sorry for bothering you again.

comet_collision_v07.hipnc

Edited by fictionfxartist

Share this post


Link to post
Share on other sites

I tried using your file i just changed the source of animated object from your wings to my stone, yet that didn't work.

In my file i think the only problem is that scatter node but when i played with your file smoke object and bounding box is also a problem.

I am attaching the file where i merged both(yours and mine) file.

I've been trying to do this shot since last 3 weeks and i am facing the same problem(meteor doesn't emit fire) over & over again. I hope you are there to help me unless & until i finish this.

Thank you @Atom!

comet_collision_v07_1.hipnc

Edited by fictionfxartist

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×