Jump to content
bentway23

Random vellum points "pinned" on remeshed grid without pinning active

Recommended Posts

I'm tinkering with vellum and have a weird issue--when I use a plain grid as the cloth object and run it through a remesh, random points are/act as if they are pinned (they are given a @mass of 0), even though there is nothing set as pinned in the vellum constraint node.

I've emptied the cache, restarted, even tried a new grid with slightly a different initial subdivision count, and the result is the same--various points stay in space, pinned (although with differing initial geo point counts, the points that don't move are different).

A grid without remesh works fine. A planar patch actually works fine. I've tried various other objects, all run through remesh nodes (and without), and they all work fine. I could even assign those points a new mass through a wrangle, and that worked fine, but it seems like for something as basic as a remeshed grid, this shouldn't be happening.

What am I doing wrong here? Or is this just why god and SideFX made planar patches?

vellum_pinning_problem.hiplc

Share this post


Link to post
Share on other sites

mass = 0 means permanently fixed methinks ?

I'd just revert it back to default, ie. Mass unchanged instead of calc varying

Share this post


Link to post
Share on other sites

Aha! Actually, calculate varying IS the default (if using the "configure cloth" rather than just a bare vellum contraints node), but changing it to unchanged did the trick! Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×