Welcome to od|forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

DASD

sublime text How can you connect Sublime Text with the Wrangle SOP

I am looking into installing VEX syntax and Exhelp for Sublime text and that is easy and nice, but I realized I don't know of a good way to actually connect Sublime text to Houdini. Copy pasteing the code between Sublime text and Houdini everytime I want to test something seems like a pain.
It would be so inconvinient that I wonder whether Sublime Text would be worth the effort.
So how do you use it? Is there a way to hook Houdini and Sublime Text up to each other for a direct connection?

Share this post


Link to post
Share on other sites
EDITOR = "C:/Program Files/Sublime Text 3/sublime_text.exe"

Add to your houdini.env file something like that. In any input field in Houdini, press Alt + E. It will bring up Houdini native text editor. Press again, and it will open text in $EDITOR program, and wait until you close the program. After that, it will load any saved changes back to Houdini. Afaik, there is no way to bypass native editor.

3 people like this

Share this post


Link to post
Share on other sites

Thanks symek ! That syntax seems to be more up to date.

Thank you f1480187 ! I also found that out that the preferences of Sublime text can be tweaked  with:

"hot_exit": false,
"remember_open_files": false,

so that sublime does not save the tabs from the previous session. Now the only thing left to do is to find a way to bypass the Houdini Editor. Anybody know how to get that fixed? :lol:

 

Edited by DASD

Share this post


Link to post
Share on other sites

Im having problem with sublime 3 and ubuntu (openbox) to get any connection between them. I get sublime to open on alt+E with a .tmp.vfl file but its always empty and nothing happens on save+close either. I noticed that houdinis gui doesnt freeze either like it should do when opening external editor until its closed.

I got this to work without any hassle on win10 so maybe i need to do something spelcial on ubuntu?

Share this post


Link to post
Share on other sites

I found out how. For anyone with the same problems with ubuntu and sublime text 3 you just need to write this in your houdini.env:

VISUAL="subl -w"

It didnt work without the -w flag

Edited by Magnus Pettersson

Share this post


Link to post
Share on other sites

I have my ENV file set up for Sublime Text and all works as it should but I was wondering if there was a way to go straight to the external editor without first opening up Houdini's internal text editor first.

It seems like there's a dependency between the two but it's always nice to save a click or two where possible. :)

EDIT: I'm using Windows 10

Edited by jonmoore

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now