Jump to content
Macha

Fog, Lighting and such

Recommended Posts

There are some nodes in compositing that work with z depth information, such as lighting and fog. Over the months I have periodically tried them on 4, perhaps even 5, different machines and they only ever worked on one of them. I usually get mixed up garbled images consisting of funny colored squares or lines. The one thing all these machines had in common is windows and nvidia cards.

Do other people experience that problem or is there a trick to this?

A typical example looks like the one below.

post-4013-127682239829_thumb.jpg

Share this post


Link to post
Share on other sites

I had a similar display problem, but with the scale COP.

Turning off 'Use GPU to Assist Compositing' and 'Use Collapsible Pixel Operators' in preferences solved it.

Share this post


Link to post
Share on other sites

Thanks. "Collapsible Pixel Operators" surely never crossed my mind.

It seems better but some nodes still don't work. (Expand COP for example). It's all very mysterious. I need to test it a bit more...

Share this post


Link to post
Share on other sites

Wow, look at this craziness. I almost like it!

post-4013-127682812072_thumb.jpg

Share this post


Link to post
Share on other sites

These effects were my first experience I made with the compositor, and I thought that's why they tell it's useless for compositing.

Share this post


Link to post
Share on other sites

Surely this can be submitted in to Support as a bug.

Hardware acceleration on or off, doesn't matter.

Share this post


Link to post
Share on other sites

Yeah i get it too, cool but not very useful :)

weirdbutcool.jpg

Share this post


Link to post
Share on other sites

Old thread, same problem. Some versions of H work and then it's all messed up again. What's going there?

Recently I can't use any of the fog, lighting, and color correction nodes. I either get crashes or those funny windows popping up and crazy graphics.

post-4013-130076086482_thumb.jpg

Share this post


Link to post
Share on other sites

And here is what I get when I blur a shape...

Don't know why cops have deteriorated so much lately...

post-4013-130076280509_thumb.jpg

Edited by Macha

Share this post


Link to post
Share on other sites

I would suggest turning off "Use GPU Acceleration" if you've turned it on. This option uses GLSL to process images for certain COPs. Unfortunately, unlike the rest of Houdini, GLSL code is compiled at runtime by the compiler in whatever driver version you're using. Updating our gcc or MSDev version for a new build often causes compiler errors, but we resolve all of these before the software can be shipped out, and the compiler version is completely under our control.

Not so with GLSL - the compiler version is out of our hands, and unfortunately code that compiled before sometimes stops working as driver developers optimize and add features to it. Ideally this wouldn't happen, and GLSL code that was written 2 years ago would work on any current AMD or Nvidia driver. However, this just does not seem to be the case and it requires constant maintenance (the same goes for viewport shaders). Unfortunately, this same issue will also apply to OpenCL.

Doing a quick search through the bug database for COPs bugs, I do not see any of the above issues submitted. As no active development is currently being done in COPs and none of the regression tests are currently failing for it, unless we receive a bug report, we won't know to fix it. Please don't assume Side Effects knows about an issue, regardless of how glaring it may seem.

Share this post


Link to post
Share on other sites

Please don't assume Side Effects knows about an issue, regardless of how glaring it may seem.

OK, I'll submit it. The problem with these kind of bugs is that I usually get a reply along the lines of "we can't replicate the problem", and I can't really say much more than "I plugged an image into the blur node" :(

It seems that at least some people experience these problems and perhaps one of the people seeing this found a solution.

So, using an old driver might solve it then?

Edited by Macha

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×