Jump to content
Macha

Houdini 11 opengl probs

Recommended Posts

My viewport is quite "sticky". Even very simple scenes slow down when rotating and moving about the scene. This goes away when I use High Quality Lighting or switch to Hidden Line mode.

I updated my driver to the latest version but now High Quality Lighthing doesn't work at all, the screen is black.

Anybody else experience this?

graphics: Quadro FX580

driver: 258.96

OS: XP32

I also get the error below whenever I start H11 or mplayer loads.

Edited by Macha

Share this post


Link to post
Share on other sites

translates to something like

Entry Point cannot be seen

Procedure entry point xxx dynamic link library xxx wasn't found.

post-4013-128039432403_thumb.jpg

Edited by Macha

Share this post


Link to post
Share on other sites

I also have this weirdness happening to me in the scene context...

post-4013-12803968001_thumb.jpg

Share this post


Link to post
Share on other sites

My viewport is quite "sticky". Even very simple scenes slow down when rotating and moving about the scene. This goes away when I use High Quality Lighting or switch to Hidden Line mode.

I updated my driver to the latest version but now High Quality Lighthing doesn't work at all, the screen is black.

Anybody else experience this?

graphics: Quadro FX580

driver: 258.96

OS: XP32

Same here using Nvidia Quadro FX 3500.

I have unchecked "Display Options -> Effects -> Material Shaders" to back to old Houdini viewport behavior.

Nothing about your others problems.

Share this post


Link to post
Share on other sites

I updated my driver to the latest version but now High Quality Lighthing doesn't work at all, the screen is black.

Anybody else experience this?

Same here too, using Nvidia 8600 GTS.. On ATI HD 2400 all works fine.

Share this post


Link to post
Share on other sites

Same here using Quadro FX4600, tested with the latest drivers (258) and rolled back to 197.

When i play with smoke sims, the viewport stick to some frames during the playback.

Edited by Pazuzu

Share this post


Link to post
Share on other sites

All current Nvidia drivers 256 and above do not work with Houdini 11 yet, as compiling the basic material shader fails with an internal Cg compiler error. We've filed a report with Nvidia and are awaiting a fix/advice on the matter. In the meantime, drivers between 185-197 need to be used.

Share this post


Link to post
Share on other sites

Works fine at my simple nv240gt with drivers v.257.21,

Share this post


Link to post
Share on other sites

It usually drops back to per-vertex (fixed function) lighting when the default shader fails to compile. But this means that HQ Lighting, Ambient Occlusion and shadows won't work. If these do work on the Nvidia 240, I'll attach that info to the bug report I've filed with Nvidia (I don't have one of those cards, myself), and hopefully that'll aid them in tracking the problem. Thanks!

Share this post


Link to post
Share on other sites

Hi

Sorry, Mark. I made mistake, it's bug.

While testing, i got:

HQ Lighting - for first activation of this option - working, then if turn off(restart), black screen or segmentation fault. Restart PC and work again... not houdini

Ambient Occlusion - same as HQL

Shadows - working

Edited by ilay

Share this post


Link to post
Share on other sites

I've managed to work around the issue in 256+ Nvidia driver versions, in Houdini 11.0.458.

In case anyone does GLSL work, indexing gl_LightSource[] in a for() loop, even if it's 0 to gl_MaxLights, will not work in a fragment shader in driver version 256 and above. You'll have to unroll the loop.

Share this post


Link to post
Share on other sites

I got the same problem.

The viewport started to become sticky as long as I added something into the scene (just a torus and a grid).

My graphic card is Nvidia GeForce 8800 GT (on the MacPro 3,1, MacOS 10.5.8),

but I don't know how to get the info of the version of my graphic card.

but all the icons are displayed normally.

Share this post


Link to post
Share on other sites

Same here using Nvidia Quadro FX 3500.

I have unchecked "Display Options -> Effects -> Material Shaders" to back to old Houdini viewport behavior.

Nothing about your others problems.

Thanks a lot, it has just helped me on a Mac. Viewports are with quick interaction again.

Share this post


Link to post
Share on other sites

Not working yet, black objects when 'Material Shaders' is checked.

Nvidia Quadro FX 3500

Driver version: 258.96

Houdini 11.0.460

Windows 7 64 bits.

Display options warning icon message:

Texture use: 0 MiB (0 maps)

Framebuffer: 31 MiB (1052x683)

Warning: Omnidirectional area shadows are not supported by DX9 hardware.

Omnidirectional point shadows will be used instead.

Share this post


Link to post
Share on other sites

Not working yet, black objects when 'Material Shaders' is checked.

This is fixed in tomorrow's build, 11.0.462. The problem affected DX9-class hardware (such as the Quadro x500 series, GEforce 7x00 & 6x00, ATI X800/600/300, X1800/1600/1300). I believe you can work around it by enabling HQ Lighting in the meantime.

Share this post


Link to post
Share on other sites

This is fixed in tomorrow's build, 11.0.462. The problem affected DX9-class hardware (such as the Quadro x500 series, GEforce 7x00 & 6x00, ATI X800/600/300, X1800/1600/1300). I believe you can work around it by enabling HQ Lighting in the meantime.

Great Mark, I will test 11.0.462 version.

Yes, I can work unchecking "Material Shaders" in "Display Options".

Share this post


Link to post
Share on other sites

Macbook, Intel GMA X3100. In 3d viewport options "Material shaders" checkbox is disabled, but "Transparency" checkbox in same area is enabled, I have turned off transparency. But viewport is very very slow, although viewport in Houdini 10 interacts normally in scenes with simple geometry. Maybe SESI had turned on "Material shaders" by default, because when I am changing material peoperties in the parameter editor, performance are slightly slowing down. Houdini 10 viewport interacts well using this obsolete videocard.

Share this post


Link to post
Share on other sites

Macbook, Intel GMA X3100. In 3d viewport options "Material shaders" checkbox is disabled, but "Transparency" checkbox in same area is enabled, I have turned off transparency. But viewport is very very slow, although viewport in Houdini 10 interacts normally in scenes with simple geometry. Maybe SESI had turned on "Material shaders" by default, because when I am changing material peoperties in the parameter editor, performance are slightly slowing down. Houdini 10 viewport interacts well using this obsolete videocard.

Try setting the environment variable HOUDINI_OGL_DISABLE_FBO = 1. This will also disable color correction in the 3D viewport, but it may restore interactivity. Apple's Intel video drivers are better than Intel's own, but it's still pretty tricky to get decent performance out of most Intel GPUs.

Intel graphics aren't supported by SESI, so very little attention is given to them. Even the new Intel HD 4500 is tremendously slow with Houdini (even slower than using Software GL, ironically enough).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×