Jump to content
Sign in to follow this  
RAJK

problem with Mosaic Node

Recommended Posts

Hi, I've been loading in a series of .exr files in the IMG context, and putting in a scale node + a mosaic node after that.

See the image attached.

But the problem is the mosaic node is not displaying the images in a tile, as per what i understand the function of what the Mosaic node does.

Any idea what i'm missing out?

16_Jul2013b.jpg

Share this post


Link to post
Share on other sites

it seems that the Scale COP has problems with GPU compositing (at least on my end)

go to Edit/Preferences/Compositing/Cooking and uncheck Use GPU to Assist Compositing

then either clear the COP cache and recook or close and open scene

if that doesn't help then it may be different problem for you

Edited by anim

Share this post


Link to post
Share on other sites

Update :

confirmed.

Actually Use GPU to Assist Compositing was already unchecked on my side.

But i cleared the COP cache and noticed something else : the tile size.

I adjusted the tile size to 512 by 512, saved everything, restarted Houdini and it worked!

Thanks so much anim!

Edited by RAJK

Share this post


Link to post
Share on other sites

Anyone knows if the GPU compositing is recommended? I assume it's not because it's not on by default and I noticed some visual artifacts in certain nodes. So it's not feature complete yet but might be in the future?

Share this post


Link to post
Share on other sites

I usually use CPU compositing, but when I notice artifacts I turn it of the first thing

It seems that SESI is not focusing on COPs at the moment so probably not near future

and from the fact that they seem to be struggling with viewport compatibility among GPU cards I can only guess that GPU cops may have similar compatibility problems so it is possible that there is some dream configuration where GPU compositing works without problems

  • Like 1

Share this post


Link to post
Share on other sites

I usually use CPU compositing, but when I notice artifacts I turn it of the first thing

It seems that SESI is not focusing on COPs at the moment so probably not near future

and from the fact that they seem to be struggling with viewport compatibility among GPU cards I can only guess that GPU cops may have similar compatibility problems so it is possible that there is some dream configuration where GPU compositing works without problems

If it is a bug, submit it.

If it is an RFE in compositing, submit it.

For COPs it's tricky as to replicate the issue we need the image files which can be large and can contain confidential information. This expedites the fix ten fold as we don't have any guesswork as to your scenario.

Compress and upload to our ftp site as anonymous with your email as the password and make reference to uploaded file in your submission.

Mangle the image up but still replicate the issue you are having if confidentiality needs to be maintained.

  • Like 1

Share this post


Link to post
Share on other sites

Thanks guys. I submitted an issue that I saw with the Noise COP using Sparse Convolution and Alligator when GPU compositing is on. It looks like this:

http://i.imgur.com/36uMUpW.jpg

Basically ring artifacts that do not happen normally if you turn off GPU compositing.

Share this post


Link to post
Share on other sites

I don't know what you wanted it to look like, but I consider this a happy mistake! :)

... not helpful, I know... :lol:

  • Like 1

Share this post


Link to post
Share on other sites

Basically the rings shouldn't be there :)

I don't know if SESI has plans to revamp the COP context though. There are more serious bugs that I have discovered such as deadlocks in compositing threading ;)

Share this post


Link to post
Share on other sites

Ran into the same issue that OP had. After a couple of hours of trouble shooting, the only way I could get it to work was to hit the play button and let it run through the whole frame range.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×