Jump to content

Fluid From Object Won't Remain In FLIP Tank?


Recommended Posts

Hi All,


I am trying to make a simple body of water, derived from a cube, splash around a medicine bottle.


I created a FLIP tank to be the domain for the simulation. The bottle mesh is a rigid body object. I placed a cube in the FLIP tank as well and converted it to fluid to be the initial fluid for the tank.


However, this does not work. The cube of fluid I created just falls out of the tank and does not recognize the walls of the FLIP tank. Does anyone know how to fix this problem?


How do I let the fluid object know it is a participant in the FLIP tank?




Link to comment
Share on other sites

You have created two separate FLIP simulations. (two FLIP solvers)


The first one has an empty initial object, but correctly set closed boundaries and a resized domain.

The second one has your cube as initial data, but does not have closed boundaries and has the default domain extents.


You could e.g. delete "fliptank" and "filpsolver2" nodes and connect your flipfluidobject1 to flipsolver1

Link to comment
Share on other sites

Thanks for the tips, I wondered about the multiple solvers. I thought Houdini just simply summed all that because the result gets routed to a single node. If I delete the FLIP tank and flipsolver2 my inital fluid just falls through the floor, no boundaries.


In this example I have created cube based walls, an RDB floor and the bottle all as rigid body participants. This does keep the fluid inside the required area but I still can not get the fluid to avoid the bottle in the scene...



Edited by Atom
Link to comment
Share on other sites

Ah I forgot to specify that you should enable "closed boundaries" on your flip fluid object.


For the bottle, your flip resolution is so low that the bottle doesn't resolve well into the collision field of the fluid sim. Even if an object's own collision volume representation looks fine, you should always check how it looks like in the collision field of the simulation/solver.



Link to comment
Share on other sites

I am still learning the FLIP system. So to increase fluid resolution do I decrease particle separation? Or is there another setting for turning up the fluid resolution?


Yepp, exactly that. The volume resolution is Grid Scale * Particle Separation, so in your scene the individual underlying voxels are 0.2*0.2*0.2 in size. Your bottle is 0.19*0.69*0.34 in size, so it is no wonder the simulation does not see it properly.


Also, if you MMB over any node in the dopnet, you will see that the overall resolution of your sim is 22*14*14, which is quite low.

Edited by eetu
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...