Jump to content
Sign in to follow this  
Atom

[SOLVED]A Clean Inner Extrusion?

Recommended Posts

Hi All,

 

I have a sphere that I have clipped. I want to extrude the sphere inwards so it looks like it has some thickness once we see inside. I have used a PolyExtrude and it does work but the outer faces get messed up and it is no longer sphere like along the outside. What is the trick to extruding without destroying the outer faces?

 

NOTE: I don't want triangles or squares to show on the outer surface, just a clean continuous sphere-like surface.

post-12295-0-14609700-1434130927_thumb.j

Edited by Atom

Share this post


Link to post
Share on other sites

PolyExtrude SOP?

 

edit: Right you tried that, sorry. Why isn't it working? Works fine for me.

extrude_dv.hipnc

Edited by Skybar

Share this post


Link to post
Share on other sites

From that screenshot it seems you are actually using the Extrude SOP and not PolyExtrude. From what I understand Extrude is primarily meant to be used with text and other simple curve shapes, so if you're working with a polygonal mesh, stick with PolyExtrude. 

Share this post


Link to post
Share on other sites

Correct, jrockstad. I was using Extrude instead of PolyExtrude.

 

However, even if I use PolyExtrude I still cannot achieve the goal of a smooth outer sphere with a sharp clip edge. I added a Facet and unique points which gets me the sharp edge but the inside of the sphere is faceted as well (red). How do I get both options in one object? (i.e. it has to render well)

post-12295-0-42648000-1434203660_thumb.j

Edited by Atom

Share this post


Link to post
Share on other sites

Try adding vertex normals to your mesh. There are a few different ways to do this including the Facet SOP which you're already using, but I like to just use the Normal SOP. Smoothing / subdividing should also give you a cleaner rendered mesh.

 

Clarification: I misspoke - you're not actually adding vertex normals by cusping polygons with the Facet SOP, but you achieve the same effect as doing do. Only the Normal and Vertex SOPs will actually apply vertex normals. 

Edited by jrockstad

Share this post


Link to post
Share on other sites

Instead of unique-ing all the points with the Facet SOP, turn on Cusp Polygons and adjust the cusp angle.

Share this post


Link to post
Share on other sites

@Skybar: Thanks, that is close but the render still has anomalies. @ jrockstad: I tried the Normal and Vertex SOP as well and they produce final geometry that does not render correctly either. Very similar to the Facet cusp solution.

 

NOTE: Changing the Frequency on the Sphere will repair it for a fixed clip distance but as soon as I move the clip distance (I want to animate it) the Frequency no longer works and the anomalies appear again.

ap_clipped_sphere.hipnc

post-12295-0-49712700-1434249900_thumb.j

Edited by Atom

Share this post


Link to post
Share on other sites

Thanks Marty, I think that does it!

 

I like the fact you added an inside color as well. :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×