Jump to content

Point VOP error on Ubuntu

Recommended Posts

Hi everyone! 

Few days ago I've installed Houdini 15.0.347 (production build, apprentice license) on a my newly purchased custom built workstation. Everything went okay. Installation smoothly finished without any warning. However one little thing is blocking me from further exploration and that's the Point VOP node which on my system (ubuntu 15.10) simply doesn't work. Never. Not even in the fresh completely blank file. 

Right as I plug in the geometry data, boom, it goes down with error (please see attached picture) 

Moreover the funny thing is when I save the "corrupted" point vop to a separate file and open it on mac osx, it works. So it's definitely something wrong with my system, or maybe with linux gcc compiler? (The version I have is 4.9) 

Anyway I wonder, has anyone here ever encountered an issue like this before? Or maybe someone here has at least clue of what's going on, since I positively don't icon_smile.gif


Link to comment
Share on other sites

Thanks for the tip, fathom. So do you think it has maybe something to do with other applications which altered some paths for Houdini on my system? Is there a way to reset those paths or return the environment back to the working state?


When I type "which vcc" it outputs a SyntaxError: invalid syntax. That means it's bad or am I doing something wrong? (just to be clear, we're talking the python shell inside Houdini, right?)

Link to comment
Share on other sites

That sounds like a good machine - the error says it can't load the shader - I'm not sure but considering that the intel driver machine crashed, it may be that the Nvidia driver is crashing for you too. Which graphics driver do you have? In the About Houdini dialog it will say. It may be worth trying a different driver.


Edit: Same machine booted into OsX works fine. So it's either Ubuntu, the graphics drivers, or the H version number - OsX Houdini version is 15.0.294, Ubuntu Houdini version is H15.0.374 

Edited by tar
Link to comment
Share on other sites

Thanks for testing that out, lucky you to have two OS's to switch between. So I guess it's gotta be the graphics driver (or maybe that Path thing fathom suggested? ). I registered the error on and after upgrade to 15.0.374 it was still there, I guess that rules out the specific H version as a cause of this.


Here is complete output (including the driver informations) from the dialog window:


Platform:                 linux-x86_64-gcc4.8

Operating System:         Ubuntu 15.10
Number of Cores:          12
Physical Memory:          62,85 GB
Number of Screens:        1
    Screen 0:             1920 x 1200 at 0,0
    Work Area 0:          1875 x 1176 at 45,0
OpenGL Vendor:            NVIDIA Corporation
OpenGL Renderer:          GeForce GTX TITAN X/PCIe/SSE2
OpenGL Version:           4.5.0 NVIDIA 352.63
OpenGL Shading Language:  4.50 NVIDIA
Detected:                 NVidia Consumer
                          12288 MB
Messing with custom graphic drivers on Ubuntu almost always ended up for me with dead system for several days before I somehow magically resurrected it, returning back to official streams through hours of pain. Maybe I have some technical baggage from those attempts which is causing this problem. Now I see there is a newer version of graphic driver from Nvidia available - I'll try to focus on this part and see how far I can get. If I go silent for couple of days that means it didn't go so well :)
EDIT: I have also CUDA Toolkit installed which I absolutely need, could there be a connection?
Edited by Pavel Siska
Link to comment
Share on other sites

Yeah, the shader seems the strangest reason for this not to work, though it's worth a shot, despite all the driver issues. Try a previous stable version before the 350 branch too.


It would be best if someone else on Ubuntu tried it too. Currently gcc v4.8.4 is installed here.


Cuda shouldn't do anything but removing for a test may be the only way, though it crashes here without Cuda installed.

Link to comment
Share on other sites

Hey Marty, Thanks for your helpful assistance. Sorry for communication blackout.


I tried few other versions of nvidia drivers with no result besides paralyzing Ubuntu for few days like I predicted. But your tips has pointed me into right direction.


When I put this line:


into my houdini.env file, it WORKS! I guess it will help you too.


This hack is recommended when your interface in Houdini goes completely black - apparently Qt interface under Linux isn't integrated as well as on other OS's. There can be some connection or maybe not, who knows.


Anyway I'm super happy it's all working now,




(I'm attaching few keywords from that original error just to make it more accessible for others having this problem too)

Vex error ;_name@ Undefined op code Failed loading function Unable to load shader

Link to comment
Share on other sites

  • 10 months later...
  • 1 month later...
  • 1 year later...

I had a similar issue recently on ubuntu mate 16.04.04 lts.

I could not get Attrib VOPs from scenes from different builds working and it was very buggy. I always got Vex error ;_name@ Undefined op code Failed loading function Unable to load shader.

I was also getting No LSB modules are availableerror message after starting Houdini (16.5+) into terminal.

LC_ALL = C setting did not help me, but what solved my issue was to install lsb-core package and reboot.

So on ubuntu simply run:
$ sudo apt-get install lsb-core
and reboot.

I am posting it here in case somebody has similar problems.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...