Jump to content
Mzigaib

Flickering on large environment with high detailed geometry

Recommended Posts

I have a large terrain shot around 1K units of distance, I'll have more and bigger shots like this,  with thousands of high detailed trees and the big issue that I am having is that the threes or any high detailed geometry that are close to the camera render fine as regarded to anti aliasing and samples the same doesn't happen with the ones that are very far from the camera lets say up to 300 Units the ones around this distance tend to flicker a lot it seems that small geometries like leaves or grass are moving fast even if they are static, that happens to one frame to another even with static camera no matter what I do I can't get rid of it which is frustrating, I see the jittering in all the planes direct and indirect even thou I am not using diffuse bounces.

Things that I've tried

-Increase max/min ray samples like min 10 up to 300 max;
-Increased lights samples up to 32, including environment lights;
-Used Photons (Too many pops with objects like moving trees);
-Used pixel samples up to 12X12!;
-Increased raytrace bias up to 0.1 from there things start to get weird, I notice some improvement but not enough;
-Checked the indirect and direct planes to see the samples and it seems fine for me going from 100 up to 300 in the critical areas, let me now if you think that is a overkill or not enough it seems to work fine for the ones that are close to the camera;

Things that worth to mention:

-I am using Houdini 15.0.416 on Linux;
-The tress do have leafs with intersecting geometry so the grass, I was hoping that the bias option could help me, not quite;
-I am using 3 lights 1 direct and two environment one for direct other for reflection two different maps, but even with one light the problem persists;

Well for now is that what I can tell about my issues and experiences so if anyone has any tip regarding this problem please share I would really appreciate.

I hope that my explanation makes sense, thanks in advance.
 

Edited by Mzigaib

Share this post


Link to post
Share on other sites

How far is the geometry from the origin? Could potentially be a floating point issue if you are very far away.

Share this post


Link to post
Share on other sites

From 300 to 500 units there are tress spread around the place, what you mean by floating point issue? you mean texture issue?

Share this post


Link to post
Share on other sites
Guest tar

try to modify the camera frustum to contain only the area you are rendering, this should help, and, all computer graphics artists should read up on floating point issues in computers: You only have 5 or 6 significant digits to abuse.

Single-precision floating-point format

https://en.wikipedia.org/wiki/Single-precision_floating-point_format

'What Every Computer Scientist Should Know About Floating-Point Arithmetic'

https://docs.oracle.com/cd/E19957-01/806-3568/ncg_goldberg.html

Share this post


Link to post
Share on other sites

Oh, I though that you were referring to something Houdini specific, I know about precision I just didn't know that it could affect my render maybe they should put this on the manual. :D
Thanks for the tip I'll try that for sure and I'll let you know.

Cheers!

Edited by Mzigaib

Share this post


Link to post
Share on other sites

hi, from what you have wrote it looks like a camera or scaling problem of some kind. a few things to check:

is your camera scale 1,1,1?

what about camera clipping planes? try to change those numbers by the order of the magnitudes.

have you tried to isolate a single problematic part and render it alone to see if the problem persists?

have you tried to create a new camera and render from that one?

what if you render everything with only a simplest plain grey material?

what if you only render with one directional light that is casting no shadows?

have you tried to load your geo into a new scene and render from there?

have you tried to scale your scene down by null parenting? (just to see where the problem is coming from)

have you tried to render with different render engines? (pbr, raytrace...)

have you checked normals on your model? many times, this can be an issue. if you're not sure, try to delete them (mantra will recreate at the render time)

 

Share this post


Link to post
Share on other sites
1 minute ago, davpe said:

hi, from what you have wrote it looks like a camera or scaling problem of some kind. a few things to check:

is your camera scale 1,1,1?

Yes, it is 1,1,1 

what about camera clipping planes? try to change those numbers by the order of the magnitudes.

Didn't try that, I'll dot it for sure.

have you tried to isolate a single problematic part and render it alone to see if the problem persists?

Yes and the problem persists, if I zoom the camera close enough the problem disappears.

have you tried to create a new camera and render from that one?

Yes, the problem persists.

what if you render everything with only a simplest plain grey material?

Yes, problem is the same but I'll check again

what if you only render with one directional light that is casting no shadows?

Not exactly, I tried with one light and the problem persists but not without shadows I'll try that.

have you tried to load your geo into a new scene and render from there?

I did try it with my tree asset and I got similar results with the same "try it all and didn't get rid of it" situation but it seemed a little better.

have you tried to scale your scene down by null parenting? (just to see where the problem is coming from)

I already got my scale very close to 1 Houdini unit = 1 meter so I if a tree is 5 meters they are 5 Houdini units.

have you tried to render with different render engines? (pbr, raytrace...).

No but I'll check this one out.

have you checked normals on your model? many times, this can be an issue. if you're not sure, try to delete them (mantra will recreate at the render time).

Yes I did check it, the thing is the same tree close=fine away=problem.

 

Thanks very much for the tips guys I'll try those for sure and I let you know.

Cheers!

Share this post


Link to post
Share on other sites
35 minutes ago, marty said:

try to modify the camera frustum to contain only the area you are rendering, this should help, and, all computer graphics artists should read up on floating point issues in computers: You only have 5 or 6 significant digits to abuse.

Single-precision floating-point format

https://en.wikipedia.org/wiki/Single-precision_floating-point_format

'What Every Computer Scientist Should Know About Floating-Point Arithmetic'

https://docs.oracle.com/cd/E19957-01/806-3568/ncg_goldberg.html

I cant remember exactly, but some guys I know had some problems with this like 2 years back. It boiled down to SOPs being in 32bit and Object Level in 16bit (or the other way around). To solve it they moved the geo to origin in one of these spaces and then moved it back in the other. Cant remember the details but I think it was something along those lines. Maybe you know Marty?

Share this post


Link to post
Share on other sites

Just to update some info, I am using packed objects to spread my trees and grass with a copy sop it is a lot of threes and grass maybe some one have more info on those lines.

Share this post


Link to post
Share on other sites

i assume you did, but have you tried to render it unpacked? (or part of it)

you said that problem is still there when you load the asset into a new scene. that would make me investigate the asset itself rather than anything else.

Edited by davpe

Share this post


Link to post
Share on other sites

I didn't because if wasn't for packed or any delayed loader it's going to be impossible to manage the shot each tree is around up to 1.5k polys and I have a couple thousand of them but I did render the trees alone close to the camera and no problem.

Share this post


Link to post
Share on other sites

i understand that but you said that the same problem persists with even a single tree. so have you tried to unpack that and scatter, say, 10 trees in different distances from the camera? or, another thing to try is to render it as a a geometry procedurals. good for very heavy geo. the point is to find out if it haven't gone wrong by packing the geo.

Share this post


Link to post
Share on other sites

Do you have a rendered movie we could look at?

My first thought is poor texture or shadow maps. Like anti-alias or mip-mapping.

Are you using shadow maps or raytraced shadows?

Edited by Atom

Share this post


Link to post
Share on other sites

The way I am testing it since it is a heavy scene is to isolate the further trees and render 2 frames so I go back and forth to see the issue, the thing is that those two frames contains no animation for the camera and trees so everything is static and even so you can see the pixels shifting. Like I said if you go back and forth you are going to see the problem this setup is 6X6 pixel samples with min max rays 1/100 noise 0.005, raytrace bias 0.01, bias along normals, 3 lights like i've said before and no bounces.

flicker_test.0002.jpg

flicker_test.0001.jpg

PS: those trees are 500 units from the camera.

 

Edited by Mzigaib

Share this post


Link to post
Share on other sites

oh, this really looks like just a sampling. i was imagining some crazy black polygons flickering :) you said that increasing the sampling doesn't make it go away? can you post a screenshot of your mantra sampling tab? 12x12 pixel samples seems like enough for this but it depends on other numbers as well. what resolution are you rendering to? can you see the flickering in the alpha channel too?

Share this post


Link to post
Share on other sites

This one I was rendering at 1280X720 but the same happens at FULL HD and also this one I am rendering at 6X6 but 8X8 and even 12X12 the same result the alpha is fine, I also think it is a sampling problem but one that doesn't want to go away, and since I am going to render to FULL HD to project at movie theater even the slightest jitter can be noticeable it needs to be at least acceptable.
here are my settings for this one.

my_settings.jpg

Share this post


Link to post
Share on other sites

what happens if you turn off the Ray variance antialiasing and boost up your pixel samples to like 16x16? and then, next test, set the pixel samples to 6x6, min samples to 4, max samples to 16. if you have any transparency on your materials, try to mess with stochastic transparency (try to turn it off and values 1-16). keep the Raytracing bias at 0.001 in case you have changed it.

Share this post


Link to post
Share on other sites

also, try to render to a larger resolution. many times it's cheaper to render bigger image with lower sampling and then scale it down in comp.

Share this post


Link to post
Share on other sites
Guest tar

The intersecting geo is the problem IMO. That should be cleaned up. If it's not possible, then temporal frame blending in Nuke may be the best option - averaged over a few frames.

Share this post


Link to post
Share on other sites

Thanks for the tips I'll try that, I'll also try to adjust the stochastic option I didn't touch that yet.

Guys I can't thank you enough for the attention you are awesome, I'll update as soon as I have more info.

 

Cheers!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×