Jump to content
Mzigaib

Flickering on large environment with high detailed geometry

Recommended Posts

Maybe if there was a way to increase light samples on the object according to his distance from the camera that could help, so since they are instances the ones that are further away get more light samples than the close ones.

 

Edited by Mzigaib

Share this post


Link to post
Share on other sites

i think that is possible if you add a properties vop to the shading network connected to outputs and add the light samples as a parameter...then you can override that parameter with an attribute on the geometry....

Share this post


Link to post
Share on other sites

It looks to me that the problem is in the specular of the leaf material. Try turning it off for distant trees. If you are using an HDRi light in the scene try blurring it out. Some of those fireflies might be coming from HDR high frequency values. You may want to drop the Color Limit on the Mantra node down to 4 from 10.

Share this post


Link to post
Share on other sites

Considering all tips I may have found the main problem and I've found that the values to solve the problem may have to be really huge, huge comparing to my usual setup. I've found that the environment result is working fine so far as for the direct lighting I have a back sunlight which the results are really flickering even with a light sample of 64 and pixel samples 8X8 so now I am going to try to increase the light samples lot see what happens, I'll update soon as I have more results.

Edited by Mzigaib

Share this post


Link to post
Share on other sites

Not infront of Houdini atm, but I've had issues with crawling/flickery reflections before (mainly highlights). The only thing that really helped was cranking pixel samples really really high, OR adding the "Jitter" parameter on your Mantra ROP and turning it off. Don't know if its changed anything in later houdini versions, but you could try that if you haven't already.

Share this post


Link to post
Share on other sites

Thanks for the tip dude! Didn't try the jitter option yet, I'll do it for sure I'll let you know the results.

Edited by Mzigaib

Share this post


Link to post
Share on other sites

A little update:

it seems that to reduce the flickering the only way I found was to increase pixel samples a lot, no matter how I increase ray and light samples with lower pixel samples for small and with high frequency details it doesn't work and whats funny is that if I reduce ray and light samples and increase the pixel samples I got a faster render comparing to lower pixel samples and higher light and ray samples, I still get noise but it is acceptable except for some fireflies but I think with a high ray and light samples and can get it acceptable too.

Anyway I got very small difference in noise between 12X12 and 16X16 pixel samples but the render times are very different more than double.

Anyway if you want high quality result in this case there is no magic you have to crack settings up. 

Any tips still will be welcome.

noise_check_12X12.gif

12X12

noise_check_16X16.gif

16X16

Edited by Mzigaib

Share this post


Link to post
Share on other sites

Not yet, I also forgot to decrease the color limit that's why the fireflies are shiny, but I'll try.

Thanks!

Edited by Mzigaib

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×