Jump to content
Atom

Undo In The Animation Editor?

Recommended Posts

Hi All,

Is it just me or is the Undo completely broken in the Animation Editor for Houdini 15.5.607?

Try this...

Copy some keyframes to the clipboard.

Move to another location in the time line.

Paste the copied keyframes.

Press UNDO and nothing happens?

 

Share this post


Link to post
Share on other sites

Can't help since I haven't installed 15.5.607, but I can tell you that it's working on 15.5.523

Share this post


Link to post
Share on other sites

Seems to be working fine on my end.
animation_editor_undo.gif
H15.5.607 Indie
Windows 10
Nvidia GeForce GTX 560

 

Share this post


Link to post
Share on other sites

Thanks for the feedback. The only thing I notice I am doing differently is I have multiple channels in the Animation window. Also I notice that all my troublesome keyframes are for custom channels I have added to the node. Perhaps a more detailed description of the bug I experience would be...

Undo does not work in the Animation Editor when the keyframes are channels and not native parameter such as tx,ty,tz.

Drop a few float fields into your node, and animate them with key frames. Then try the undo.

Edited by Atom

Share this post


Link to post
Share on other sites

Ok, I tried adding 3 float spare params and keyframed those randomly. The undo still seems to work fine on my end.

I've attached a simple scene file that I used for testing. It consists of a Geometry Level object with animated spare paramters, and A a SOP Level node with animated parameters, both contexts seem to work ok.

Could you maybe create a similar hip file for us to test? :)

H15.5.607 Indie

anim_editor_undo.hiplc

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×