Jump to content
Visual Cortex Lab

Houdini And Crap Ati Cards

Recommended Posts

after being first time deeply into od:wiki i went into the Houdini Customization page.. and i read about the "hconfig" command from command line.

well.. playing with some variables I'm now able to use houdini on my laptop which have a ATI Radeon Mobility 7500, which is known to not be the best card for Houdini (if not the worst cause its ATI).

at first I solved the UI refresh and draw problem by settings the Accelleration (Display properties-> advanced-> troubleshoot->accelleration) down until you disable Directdraw features, Houdini UI was smooth and everything was fine, but i had the problem with playing videos or medias in general since Directdraw were disabled, scaling of a MOV or AVI was crap and boring to enable/disable accordingly to my actual Laptop use.

anyway, to make it short, I found that with some variables set (My computer->properties->environment variable->user/system vars) the problem is solved and I dont need to disable DDraw accelleration (none actually) and I have Houdini running smooth.

the following are my custom variables now:

HOUDINI_OGL_DBL_BUFFER_FIX = 1

HOUDINI_OGL_DISABLE_SMOOTH_STIPPLED_LINES = 1

HOUDINI_OGL_MARQUEE_FIX = 1

HOUDINI_OGL_RASTER_DISPLAY_FIX = 1

HOUDINI_OGL_SOFTWARE = 1

I also set the UI scale to 85 but that was just a personal choice as stated from od:wiki .. I'm running 1400x1050 15" resolution and everything is now cool..

jsut wanted to share this, It might solve UI problems with other ATI boards, I cant check it since I never had ATI (and never I will) on my workstations.

cheers!

Share this post


Link to post
Share on other sites

Wow, that's pretty extreme. You've complete turned off hardware acceleration. :) Do you need all of them? Esp. HOUDINI_OGL_SOFTWARE.

Share this post


Link to post
Share on other sites

well... not all of 'em .. i just found different behaviors with differentr settings.. and with this one the UI is really fast.. the Viewport is what you can expect from a crappy 32mb Ati Mobility 7500 :) which i'm really sure is crap, and surely not OGL accellerated.

I can tell you for sure that I wont use Houdini without those settings on my Laptop :) .. obviosly nothing have to be done on my workstation with a QuadroFX board .. this was just for Laptops without a Geforce or with boring ATI cards. never tried Houdini on a X600 or X300 (or X800) yet .. i'll might give a try on a friend's laptop to see if the UI have problem there too.

anyway, with all those settings I can now use Houdini with no problem (and one of 'em was, still have to check if still is, the crash when selecting nodes in networks, which I'm pretty sure was caused by card refresh problems).

I'll might give a try one by one again and give here the feedbacks. I cant remember which one was, alone, the really needed to get rid of the really slow UI refresh problem.

cheers!

Share this post


Link to post
Share on other sites

ok i found the minimum environments settings for a perfect/smooth UI with my ATI Radeon Mobility 7500:

HOUDINI_OGL_DBL_BUFFER_FIX = 1

HOUDINI_OGL_RASTER_DISPLAY_FIX = 1

HOUDINI_OGL_SOFTWARE = 1

without any one of the above the UI become slow or annoying artifacts are still present.

cheers.

Share this post


Link to post
Share on other sites
HOUDINI_OGL_SOFTWARE = 1

Weird that swtiching off all OpenGL acceleration speeds things up.

Share this post


Link to post
Share on other sites
I also set the UI scale to 85 but that was just a personal choice as stated

I do this exact ratio too. I very much prefer it and tend to think it should be the default for Houdini :)

Also, the Smooth Lines option can really hurt performance - especially on high-resolution geometry and/or consumer level graphics cards. This too might be a poor default IMHO.

Share this post


Link to post
Share on other sites
I do this exact ratio too. I very much prefer it and tend to think it should be the default for Houdini :)

Also, the Smooth Lines option can really hurt performance - especially on high-resolution geometry and/or consumer level graphics cards. This too might be a poor default IMHO.

21127[/snapback]

oh yeah.. i forgot.. even if i love 'em i had to remove Smooth lines on my laptop too. on such cards it really makes the difference.

cheers

Share this post


Link to post
Share on other sites
Weird that swtiching off all OpenGL acceleration speeds things up.

21103[/snapback]

well i dont know.. but.. obviously "speed" will definetly slow (and it does) when scene starts to have many objects and such in viewport... but the overall performances are really nice for an "apprentice" workstation (or craptop :)) since the UI is what also makes you "feel" a speed somehow .... and with those environment the UI is lightfast, therefore the overall use, again, until you dont have heavy scene which kills down the 3d viewport.

specially since this laptop is from a friend and I had to "analyze" it well before confirming my intention to buy it (even if cheap) i had to be sure that houdini was working enought to enjoy it, and now it does.

figure, at first before cosidering such variables, the best way to have a smooth and fast UI was to disable gfx board accellerations down until you even disable DirectDraw and such.

therefore, yeah ... pretty weird "disable accellerations = faster" :)

cheers

Share this post


Link to post
Share on other sites
I do this exact ratio too. I very much prefer it and tend to think it should be the default for Houdini :)

21127[/snapback]

Gah ... I use 105 ...

As for the video acceleration stuff, it likely means that the ATI drivers were encountering situations that it didn't know how to accelerate and doing such a bad job at software emulation that Microsoft's software OpenGL implementation was faster.

Share this post


Link to post
Share on other sites
Weird that swtiching off all OpenGL acceleration speeds things up.

21103[/snapback]

It does, oddly enough. Also at school I turn off OpenGL and activate environment variables such as the "double buffer fix", which - most of the time - tend to speed things up quite a bit!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×