Jump to content
Sign in to follow this  
netherknight

NURBS Curve not rendering correctly

Recommended Posts

I'm running into an issue. I'm using the convert node to change my wires to NURBS. However, when I render these out it renders them as if the conversion hasn't happened. 

Is there a good reason as to why this is happening?

image.thumb.png.dca3ca7c6145feea1599016e9c780f1a.png 

Share this post


Link to post
Share on other sites

instead of converting them to NURBS you can check Render/Geometry/Render Polygon Curves As Subdivision on your object or add that property to the shader

Share this post


Link to post
Share on other sites

I'm not sure if this is a bug or not (18.0.391), but I noticed that "Render Polygon Curves As Subdivision (Mantra)" only works if you also have "Render Polygons as Subdivision (Mantra)" enabled.

Share this post


Link to post
Share on other sites

works for me without the need to have both enabled, same version

just note "Render Polygon Curves As Subdivision (Mantra)" works for open curves, closed curves render as polygons (not ribbons) and those will use only "Render Polygons as Subdivision (Mantra)" property

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×