Jump to content
Sign in to follow this  
Alain2131

Issue with Display Flag when selecting geo on HDA

Recommended Posts

Hey there !

I've got an issue where I have a group on my HDA (or multiple, doesn't matter) to do some stuff, but when I click the "select button" to start the selecting in the viewport, the display flag doesn't go on the group node. It stays where it was set when the HDA was saved.
So in this example, the display flag is set on the Output node, and when selecting the prim or the point, we stay on the tube geo instead of going to the cube or the sphere
I made sure to have all the nodes as "Editable" in the HDA, just in case.

Here's a bare-bone setup showcasing the issue. The Group parameters on the HDA were created by drag-and-dropping each group nodes' parameter on the HDA, and I changed the Action Button Script a little bit to make it work.
In this gif I tried with two version of the same HDA, one at the OBJ level, the other at the SOP level. Both have the same behavior.

groupDisplayFlagHDA.thumb.gif.2e66fac70f063b6e68ede10195911947.gif

Looks like the display flag isn't able to be changed, since the HDA is locked.
So when I unlock the HDA, then the selection stuff works correctly ! Until I lock it back up.

I would assume that even when locked, the display flag would do that stuff with the render/display flags combo where upon clicking the "start selection" button, the render flag stays on the currently-displayed node, and the display flag moves (temporarily) onto the parent of the group node, until the selection is done.
I swear that worked before.. I seem to remember that I had to specify the parent of the group node as an Editable Node in the HDA, and then the render/display flag combo worked... But I might be mistaken ..?

Is there a workaround ? Did it really work before ?

Thanks !

groupDisplayFlagHDA.hipnc

test_groupSelect_obj.hdanc

test_groupSelect_sop.hdanc

Share this post


Link to post
Share on other sites

Try deleting the Output node. When an output node is present, it is assumed that is the final output, regardless of the Display flag.

Most of the time, you want that in an HDA so it always functions, even if you forget to move the flag before saving it.

Edited by Atom

Share this post


Link to post
Share on other sites

Hey Atom !

Removing the Output sadly didn't work.

But I did find a workaround !
If I put the Group node in a subnet, then it works !
It's in there, alone, and in the Type Properties I specify only the Subnets themselves as Editable Nodes. And when I do the selecting, Houdini automatically places a null between the input #1 and the group node

groupDisplayFlagHDA_workaround.thumb.gif.f0b1786db4f5834937c0d3304db456e0.gif

So at least now it works, but if someone has an idea so that I don't need this hack, I'd appreciate it !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×