Jump to content
LaidlawFX

Nuke Deep Compositing

Recommended Posts

A little late to the game, but OMG it's working! Thank you Szymon!

Nuke 6.3v8 / Houdini 12.0.634 on Fedora 14.

post-3604-134036282384_thumb.png

Share this post


Link to post
Share on other sites
rat4nuke now compiles with Nuke7.0 (tested with N7.0v4 and H12.1.185). Edited by SYmek

Share this post


Link to post
Share on other sites

Under Ubuntu 12.04, I'm getting the following error:

undefined symbol: _ZN14IMG_DeepShadow13getWorldToNDCEPK10UT_OptionsR11UT_Matrix4TIfEiib[/CODE]

I'm using Houdini 12.1.77 and Nuke7.0v2.

Any clues?

Thanks in advance!

Share this post


Link to post
Share on other sites

Are you sure you have h12.1 libraries in a path, not h11? These are errors related to functions missing in H11. I haven't seen them in 12.1.185 .

Also Makefile relies on standard houdini environment variables, so the right version of houdini_setup has to be sourced before build.

Share this post


Link to post
Share on other sites

Thanks for the support Symek!

I don't think I'm doing something wrong. But I can show you.

Just to be sure, let me check variables and versions.


The Houdini 12.1.77 environment has been initialized.
fabiano@fabiano-pc:~$ echo $NDKDIR
/usr/local/Nuke7.0v2/
fabiano@fabiano-pc:~$ echo $LD_LIBRARY_PATH
:/opt/hfs12.1.77/dsolib
fabiano@fabiano-pc:~$ echo $NUKE_PATH
/home/fabiano/Documents/NUKE/plugins
fabiano@fabiano-pc:~$ ls /home/fabiano/Documents/NUKE/plugins
picReader.tcl ratReaderDeep.so ratReader.so
[/CODE]

Then lets execute Nuke.

[CODE]
fabiano@fabiano-pc:~$ /usr/local/Nuke7.0v2/Nuke7.0 --nukex
NukeX 7.0v2, 64 bit, built Dec 8 2012.
Copyright (c) 2012 The Foundry Visionmongers Ltd. All Rights Reserved.
Disk cache /tmp/nuke/??: 12MB (1% of 10240MB) used in 1 files.
[/CODE]

When I try to load a rat file I get this error.

[CODE]
[17:34.58] ERROR: deepRead: /home/fabiano/.nuke/ratReaderDeep.so: undefined symbol: _ZN14IMG_DeepShadow13getWorldToNDCEPK10UT_OptionsR11UT_Matrix4TIfEiib
[17:34.58] ERROR: deepRead: /home/fabiano/Desktop/smoke.rat: /home/fabiano/.nuke/ratReaderDeep.so: undefined symbol: _ZN14IMG_DeepShadow13getWorldToNDCEPK10UT_OptionsR11UT_Matrix4TIfEiib
[17:34.58] ERROR: deepRead: Cannot open deep reader: /home/fabiano/.nuke/ratReaderDeep.so: undefined symbol: _ZN14IMG_DeepShadow13getWorldToNDCEPK10UT_OptionsR11UT_Matrix4TIfEiib.
[17:34.58] ERROR: DeepRead1: /home/fabiano/Desktop/smoke.rat: /home/fabiano/.nuke/ratReaderDeep.so: undefined symbol: _ZN14IMG_DeepShadow13getWorldToNDCEPK10UT_OptionsR11UT_Matrix4TIfEiib[/CODE]

Share this post


Link to post
Share on other sites

Could you try current production build (185), I find it very stable, and I suspect some bug related to missing symbols (these are rather new functions). I was pretty sure they exist in all 12.x builds but either they were added after 12.1.77 or they were omitted after initial addition. If 77 is the only build you can work on, you may also edit Makefile commenting out lines 8-10:

#ifeq ($(HOUDINI_MAJOR_RELEASE), 12)
#CXXFLAGS += -DHOUDINI_12
#endif[/CODE]

The only place HOUDINI_12 is used it exactly the one enabling projection matrix metadata support.

Share this post


Link to post
Share on other sites

Not working. I changed the Houdini version to 185. Nothing. Tried to comment lines in makefile. Nothing.

Tried to setup $HFS/dsolib with ldconfg. Nops!

I think it must be something related to Ubuntu. Is it normal to have $LD_LIBRARY_PATH always empty? Even caching to ldconfig is not working.

As far I remember, you used to work with Ubuntu, right? Why did you change?

Anyway! Thanks a LOT for your support!

Share this post


Link to post
Share on other sites

I haven't seen Ubuntu for a while now, but I don't think it has anything do to what that. Also LD_LIBRARY_PATH is usually empty at least on Centos. You may want to disable the related code at all (lines 247+ in ratReaderDeep.cpp), but this all looks odd. I haven't heard about such symptom and this plug is already used by many people afaik.

Share this post


Link to post
Share on other sites

Finally solved!

I tried rat4nuke in clean ubuntu install and everything is working. In the other machine the only big diffence is a custom Alembic build. It must be causing some conflict.

I'm really sorry for that. :unsure:

Symek! Thanks a lot for your time and amazing support! rat4nuke is really amazing! Congratulations!

Share this post


Link to post
Share on other sites

Wasn't alembic linked with older Houdini libs? It looks like. Anyway great you have finally solved it. My support was minimal, but thank you for appriation :)

ps As to Ubuntu I've switched to Centos because it seems better suited for business usage. The draw back is that it's much worse supported by packagers, so you endup compiling almost everything from scratch.

Share this post


Link to post
Share on other sites

Mark Visser has kindy updated rat4nuke for Houdini 12.5 and migrated it to github repo, which is a nice thing after all ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×