Jump to content
toadstorm

melting a textured object with FLIPs

Recommended Posts

Hello,

I'm trying to figure out how to melt an object using FLIP fluids and have the UVs melt with the object. Getting the fluid motion down isn't a big problem, but I can't get the UVs to follow along. I played around with creating a vector field based on the source object's UVs in the hopes that I could advect it in DOPs, but I can't even get the UVs to write correctly to a vector field. I also tried using an attribTransfer node to transfer the UVs from the original geo to the points created by the Fluid Source node, and then I again transfer the UVs from the imported fluid particles (in SOPs, from the Dop I/O) onto the particle fluid surface, which kind of works, but the UV seams are always incredibly distorted because I have to convert the UVs from a vertex attribute to a point attribute.

Is there a better approach to this? I know I've seen this done in Houdini but I can't find any good information on how it's done.

Thanks!

Edited by galakgorr
  • Like 1

Share this post


Link to post
Share on other sites

attr Transfer uv's to particles....sim....and attr transfer back to mesh at end...I have had sucess with this....you can also use different layers of uvs for this

Share this post


Link to post
Share on other sites

Hiya galakgorr

Sorry for the short reply but I sent it from my phone....

I have attached a scene which is one simple approach..

By using different nested geo's with different uvs all sorts of layered textured effects are possible..

Hope this help

Spev

flipUV_v001.hipnc

  • Like 3

Share this post


Link to post
Share on other sites

Thanks so much for the reply, spev!

I eventually came up with a similar solution, but I used a Fluid Source node and then transferred the UVs from the original object onto the points created by the Fluid Source, then did the same thing you did in the Particle Fluid Surface node to bring the UV attributes back onto the geometry. The only consistent issue is the UV distortion at the seams of the object, but I guess there isn't really a way to avoid that.

Again, thanks for the example scene!

Edited by galakgorr

Share this post


Link to post
Share on other sites

Is there any way to remove the seam, I increased the point counts but not working. I used 800000 points need help please

post-6051-0-64559300-1417978077_thumb.pn

Share this post


Link to post
Share on other sites

I am having this Seams, problems as well. 

Have you got any idea on this problem yet?

 

 

post-13240-0-18891300-1449497789_thumb.j

Share this post


Link to post
Share on other sites

Have you tried turning on the check box for Fix Boundary Seams of the UV Texture node?

post-12295-0-02172900-1449508700_thumb.j

Edited by Atom

Share this post


Link to post
Share on other sites

the seams come from converting your vertex uvs to point uvs.  your sim is inherently point-based, so you're losing data right away.  you might try using the rest position of your sim to access the original clean uv's from your model and see if you can avoid the seams.  i'd look at trying to grab the data using the closest point point the surface and then pulling in the uv from the vertices on the hit position.

Share this post


Link to post
Share on other sites

Have you tried turning on the check box for Fix Boundary Seams of the UV Texture node?

Hi Atom,

Thanks for the hint.

 

I am transfering my vertex UV to point UV, so I didn't place another UV texture node there.

So I not sure if it's that problem.

Share this post


Link to post
Share on other sites

the seams come from converting your vertex uvs to point uvs.  your sim is inherently point-based, so you're losing data right away.  you might try using the rest position of your sim to access the original clean uv's from your model and see if you can avoid the seams.  i'd look at trying to grab the data using the closest point point the surface and then pulling in the uv from the vertices on the hit position.

Hi Fathom,

yea. that's the problem I having how.

I didn't use any rest node before. Do you means the rest position is something like start frame of my sim? 

But I have already do the uv convert process, doesn't it give same outcome?

 

I did some checking on my uv convert on both vertex and point, they look the same and i check the point from volumn colour, It didn't show the seams,.

I am guessing some how it's the uv transfer back to mesh problem.

Share this post


Link to post
Share on other sites

Any solutions to this?

I see its possible, but im not sure how??

https://vimeo.com/113844471

 

The guy said he'd post a breakdown, but has yet to.

 

The biggest clue is

 

"my source was points from volume after i set my source i attribtransfer ( uv) from my obj to this source
after the meshing again i transfer uv and v from my cached file But a lil note in this attrib transfer my
max sample count =2000"

 

But im not sure what he means, maybe someone here could extrapolate?

Share this post


Link to post
Share on other sites

Here's an example that kinda works.

Sorry, it may be slow to compute my test file, I needed a lot of points to have a "correct" result.

 

And I'm basically treating each non connected UV as a "separate" fluid, couldn't think about any other way.

I did not change any setting in the FLIP (just the separation)

flip_conserveuv.hipnc

  • Thanks 1

Share this post


Link to post
Share on other sites

Yeah it's a little slow, but the result is pretty good! Thing is my model has an ugly uv layout, prob would need 20 or so separate objects haha. There must be a way around this? Guy who's video I sent said there were no issues with seams.

The way ive done it is choosing 'surface sop' for the flip solvers initial data type, which keeps all UVs but behaves a lot differently because obviously it just computes the surface of the object (no fills). I just bought a flip tutorial set from luxx, need to go through it and ill report back.

 

Think I'll sort out my UVs too!

Edited by jim_johnston

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×