Jump to content

Recommended Posts

Hi all

have a question. I am using voronoi fracture for chunks and inheriting velocity and active attributes in dopnet, active attribute is working fine but velocity is not working, i want the chunks on active to explode rather than simply go down. i tried sop solver in dops to bring in velocity manually using attribute wrangle and its working fine but the problem is it is continuous and pieces affected by velocity always but i want as long as active attribute is 1 on any piece it gets velocity to explode rather than continue with velocity. any help? i have attached hip file and image.

thanks in advance :)

chkbox.hip

Capture.JPG

Share this post


Link to post
Share on other sites

Here's one way, there's no doubt many ways to achieve this effect.

As you say, if you set @v in sops and enable 'inherit from points' in rbd, it only works on the first frame. if you enable 'overwrite attributes from sops' and specify v, then it clashes with the rbd solver which is also trying to set @v, and your pieces fly away.

One way around this is to detect the first frame a piece is made active, and only add @v for that frame. Here I use a timeshift to move the geometry back by 1 frame, and I copy active from the shifted geo to the normal geo with a new attib name @active_prev.

In dops, I added a wrangle that just tests if @active != @active_prev. The only time they won't be different is on the first frame the piece is made active. As such, I add @v by pulling it directly from sops. The rest of the time, rbd will set @v by itself.

rbd_active_test_trigger.gif

chkbox_fix.hipnc

  • Like 9

Share this post


Link to post
Share on other sites

Useful trick, thank you Matt !

 

Share this post


Link to post
Share on other sites
On 5/5/2016 at 7:43 PM, mestela said:

Here's one way, there's no doubt many ways to achieve this effect.

As you say, if you set @v in sops and enable 'inherit from points' in rbd, it only works on the first frame. if you enable 'overwrite attributes from sops' and specify v, then it clashes with the rbd solver which is also trying to set @v, and your pieces fly away.

One way around this is to detect the first frame a piece is made active, and only add @v for that frame. Here I use a timeshift to move the geometry back by 1 frame, and I copy active from the shifted geo to the normal geo with a new attib name @active_prev.

In dops, I added a wrangle that just tests if @active != @active_prev. The only time they won't be different is on the first frame the piece is made active. As such, I add @v by pulling it directly from sops. The rest of the time, rbd will set @v by itself.

rbd_active_test_trigger.gif

chkbox_fix.hipnc

Oh yes!! that's gr8 although i got late to watch this. i don't know why od forum didn't send me notification about this reply. thanks a lot

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×