Jump to content

Recommended Posts

Hey Guys, 

I have a bunch of jellies and a want to do a vellum soft body sim on them but the issue is that they all intersect and I don't want that. 

So I threw them in foreach and scaled them down. 

Now I want to scale them up while doing the vellum soft body sim. I tried the pressure thing already but it destroys the shape completely. So I went with a sop solver but that doesn't seem to work with vellum. 

Attached you find an example file.

 I hope somebody can point me in the right direction. 

 

Cheers, Lucas 

jelly_lb_v003.hipnc

Share this post


Link to post
Share on other sites
Posted (edited)

instead of Sop Solver DOP, use Vellum Rest Blend DOP

change source to SOP, and point to /obj/jelly/color1 (or some branched null from there)

hit play

you can also decrease Blend parameter and change Update Frequency to Each Frame or Substep if you don't want it to instantly assume the new rest state

 

Edited by anim
  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

scratching my head....if you don't want them to intersect....why don't you just move them further apart in transform1 ? then no need to scale down/up.

Edited by Noobini

Share this post


Link to post
Share on other sites
1 hour ago, Noobini said:

scratching my head....if you don't want them to intersect....why don't you just move them further apart in transform1 ? then no need to scale down/up.

keep in mind that people's example files may be simplified versions, he may have a box packed with jellies in mind

scaling to avoid collisions is pretty common in softbody sims and therefore useful to know how to do it

Share this post


Link to post
Share on other sites
15 hours ago, anim said:

instead of Sop Solver DOP, use Vellum Rest Blend DOP

change source to SOP, and point to /obj/jelly/color1 (or some branched null from there)

hit play

you can also decrease Blend parameter and change Update Frequency to Each Frame or Substep if you don't want it to instantly assume the new rest state

 

Thank you so much Tomas, that did the trick. 

Share this post


Link to post
Share on other sites
14 hours ago, Noobini said:

scratching my head....if you don't want them to intersect....why don't you just move them further apart in transform1 ? then no need to scale down/up.

Its a scene with a ton of jellies and they sadly intersect by layout, so I'm not able to just scale them down or move them apart. I need to keep the original position but need to fix the penetration. And then Do the simulation. 

This scene was just an easy example as Tomas said :)

Share this post


Link to post
Share on other sites
1 minute ago, bruchhagevfx said:

Its a scene with a ton of jellies and they sadly intersect by layout, so I'm not able to just scale them down or move them apart. I need to keep the original position but need to fix the penetration. And then Do the simulation. 

This scene was just an easy example as Tomas said :)

sack the entire modelling dept ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×