Jump to content

RBD issue: How can I bring them to stop?


Recommended Posts

Hello guys,

In a simple RBD simulation, when I replace the "Ground Plane" collision DOP with my Collision-Box, the rigid body objects never stop moving! How can I bring them to stop?

(When I use the "Ground Plane" node, everything is ok!). I tried to use the " rbdautofreeze DOP", but it doesn't work.


Thanks for helping.



Link to comment
Share on other sites

Are you sure your collision box is set up properly? The default setting uses a convex hull operation to simplify the incoming collision geo. Normally that will create a solid box, so your objects (which are inside the solid box) are constantly intersecting with the collision geo creating a solve that is mathmatically impossible, creating jitter. Try setting the collision type from "convex hull" to concave.

Search "Houdini RBD jitter" for endless discussions of this. There's also a good masterclass that Jeff Wagner did a while back all on collisions that is very helpful.

Link to comment
Share on other sites

As Geoff suggested, your collision surface may not be setup correctly. They're probably bouncing around due to the gaps in your vdb supplied collider. Instead, model a box with some extruded thickness and supply that, not as a vdb, but as surface polygons. VDB colliders are for pyro and flip sims.

Edited by Atom
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...